Address book entry accidently removed by clicking delete on one of the column tabs

RESOLVED DUPLICATE of bug 301296

Status

Thunderbird
Address Book
RESOLVED DUPLICATE of bug 301296
12 years ago
12 years ago

People

(Reporter: Martin Röhricht, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050715 Firefox/1.0.6 SUSE/1.0.6-13
Build Identifier: Thunderbird 1.5 Beta 1 (20050904)

By trying to customize the columns of the address book entries a right click on
one of those tabs (e.g. Name, Email, Screen Name, Organization) offers a
"Delete" option which does not work as how it is supposed to work by many users,
because it doesn't delete the column from the tabular view but it deletes the
entry from the address book.
Two issues should be addressed:
(1) Do not offer the properties options if a user right-clicks on one of the
tabs or replace them then with the customize entries.
(2) Offer a popup that asks the user if he really wants to delete this entry
(with the Name and Email address) from his address book -- to clearify this action.

Reproducible: Always

Steps to Reproduce:
1. In address book right click directly on the tab "Screen Name"
2. Choose the last option "Delete"
3. Notice that the default selected first entry of your address book is removed

Actual Results:  
The preselected entry of the address book is removed

Expected Results:  
(1) Never offered a delete option in this area
(2) Give the user a popup that clearifies his action

Comment 1

12 years ago
The issue of the columns acting like you clicked on an entry is bug 301296. The
issue of being able to undo address card deletion is bug 94407.

*** This bug has been marked as a duplicate of 301296 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 1.5
You need to log in before you can comment on or make changes to this bug.