synapse-fr.com - XML sent as text/html

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
French
--
major
RESOLVED WORKSFORME
13 years ago
3 years ago

People

(Reporter: Pierre THOMAS, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

The result of a search (Chercher) is not displayed correctly by Firefox, it is
displayed correctly by Internet Explorer / Crazy Browser.
Try for example searching for "ci-joint ci-jointe"

Reproducible: Always

Steps to Reproduce:
1.Try for example searching for "ci-joint ci-jointe"
2.
3.

Actual Results:  
List of search results impossible to read.

Expected Results:  
See Internet Explorer.
As I already said, even if the source of the search result page is not correct,
for the user : Internet Explorer is the best !!
Firefox must do the same. Courage !
I consider this as a major bug : the user switches to another browser ! If the
customer / user is not satisfied a bug is critical whichever is the sofware problem.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20050926
Firefox/1.4 ID:2005092609

WFM. Get exactly the same result for ci-joint ci-jointe in both browsers.

Comment 2

13 years ago
What kind of search are you talking about?  And in what way is the result not
displayed correctly?

Currently, when I try to "pose une question" at the URL you gave, I get a PHP
error from the site. =)
(Reporter)

Comment 3

13 years ago
With IE I got a good list, a list of links concerning the grammar of the words
typed, with Fx is was not usable (perhaps it was a warning ?)
The problem is that yesterday and today it does not work at all, I get a warning
with both browsers (!!) : 
"Warning: fsockopen(): unable to connect to synapse.servehttp.com:80 in
/home10/eq10521/html/QristalSearch/includes/functions.php on line 13"

Anyway, the sentence hereafter displayed correctly by IE is not displayed by Fx.
"Ces résultats ont été générés par le moteur de recherche intelligent Qristal -"

I'll post a new comment if it works again with IE.
Oops, didn't get back to this to comment. Back when it wasn't returning a PHP
error, it was returning an iframe containing what it wanted to be XML with an
XSLT stylesheet, but it was sending it with the content-type "text/html", which
IE merrily and incorrectly ignores, and we do not. Once they fix the fsockopen()
problem, they need to add a header() to set the content-type.
Assignee: nobody → french
Component: General → French
Product: Firefox → Tech Evangelism
QA Contact: general → french
Summary: The result of a search (Chercher) is not displayed correctly → synapse-fr.com - XML sent as text/html

Comment 5

10 years ago
I've tried this website in my browsers and couldn'd find any problems. Searching returns HTML with the correct media type and search results work seamlessly as well.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.