Multiple log-in and edit-submit problems!

RESOLVED INVALID

Status

()

Bugzilla
User Accounts
--
trivial
RESOLVED INVALID
13 years ago
12 years ago

People

(Reporter: Gordon Wayne Watts, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: 

First, I noticed that when clicking on "submit," I am re-directed to a web 
page that says I must be logged in to modify my watchlist. I WAS logged in!!

However, even AFTER I logged in and started surfing in en.Wikipedia.org, I was 
later directed to pages that still had the "log in" link -as if I were not 
logged in.

Now, I did look to see if my bugs were reported, and I admit that I saw other 
bug reports for the latter problem (showing the log-in link even after logging 
in), however, I saw absolutely no other bug reports that showed a problem like 
my initial problem, which, after I submitted an edit, then redirected me to a 
page that asked me to log in.

Oh, one other problem: Even AFTER I submit an edit when logged in, sometimes I 
see where I was not logged in -in other words, it displays my IP address 
instead of my User name, [[User:GordonWatts]] (en.Wilipedia.org)

That is, the software says I am not logged in even when I am.

Thx!

Reproducible: Sometimes

Steps to Reproduce:
1. Only sometimes when I submit an edit am I redirected to the page that says 
I must be logged in to modify watchlist.
2. Only sometimes are my edits shown as IP addresses, but other times, it 
shows my user name -if I submit it real quick. (Indicates I log out real fast!)
3. EVERY time when I log in and then navigate it asks me to log in again. 
(This is apparently reproducible.)
Actual Results:  
Numbers 1 and 2 sometimes work as expected. #3 has messed up every time (I 
only checked 2 or 3 times, I think.)

Expected Results:  
1. It should not redirect me to funny pages regarding my watchlist (whether or 
not I'm logged in) if I submit an edit.
2. When I submit an edit, it should show [[User:GordonWatts]]
3. After I navigate, it should indicate I am logged IN, not LOGGED OUT!
PS: Sorry for shouting; I get a little frustrated here, no offense intended.

I am Gordon Wayne Watts, en.Wikipedia, User:GordonWatts, formerly known as 
UserGordonWattsDotCom, who got his user name changes to be less self-
promoting, lol.

Comment 1

13 years ago
This is the Bugzilla of the Mozilla Foundation, not of Wikipedia. I think you're
looking for this information:

http://en.wikipedia.org/wiki/Wikipedia:MediaZilla
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
Severity: major → trivial
You need to log in before you can comment on or make changes to this bug.