Firefox window title is not properly highlighted when user selects a toolbar option and clicks outside of firefox

RESOLVED DUPLICATE of bug 37540

Status

()

Firefox
General
--
trivial
RESOLVED DUPLICATE of bug 37540
13 years ago
13 years ago

People

(Reporter: Yuchao719, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20050924 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20050924 Firefox/1.6a1

Firefox window title is not properly highlighted(does not turn blue if using
default Windows9x scheme) when user selects toolbar option, clicks away oustide
firefox, and clicks back to firefox's titlebar.

Reproducible: Always

Steps to Reproduce:
1.Restore a firefox window so that there is enough space to click outside of
firefox (ex: on the desktop and/or another program)
2.Select and click one of the toolbar options (ex: File, Edit View Go...)
3.Click outside of firefox
4.Click back anywhere inside firefox

Actual Results:  
The firefox titlebar is not hightlighted, even if you drag the titlebar around.
If you are using the default windows 9x scheme, then the titlebar remains grey
instead of turning blue.

Expected Results:  
The titlebar should appear hightlighted.

- I Have not tested this problem on Windows XP
- If you drag the "grey titlebar" outside of the screen boundaries, then the
section of the titlebar that was ouside of the screen boundaries will appear
highlighted.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20050926
Firefox/1.4 ID:2005092622

I tried this in trunk and branch on WinXP.
When I click File, subsequently click outside the window, the titlebar is still
highlighted. And also of course when I click inside the window again.
So the bug as you describe it, does not show up here.

Comment 2

13 years ago
I see exactly the same problem on my win98se .
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20050926 Firefox/1.6a1

Minimize, then restore firefox.
Click on a menu.
Click outside of firefox (like the desktop). (Firefox, as is expected, is greyed
out).
Click back in firefox and the title bar remains 'grey', (altough it otherwise
works normally).
Dragging an area of the firefox window offscreen, setting the window down, then
moving it back on screen, results in the the title bar area that was off-screen
to appear normal.

Having then firefox do something (like open a new window, choose a option from a
menu) redraws it normally, except sometimes for the portion around the
minimize/maximize/close buttons.
(Reporter)

Comment 3

13 years ago
Thank you crf for describing it clearly. I wasn't sure of the correct usage of
terms to describe this problem.
(Reporter)

Comment 4

13 years ago
Created attachment 197784 [details]
A jpeg example of what this bug looks like on Windows 98SE

As you can see, the titlebar is not properly hightlighted.

Updated

13 years ago
Attachment #197784 - Attachment mime type: image/bar → image/jpeg

Comment 5

13 years ago

*** This bug has been marked as a duplicate of 37540 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.