Last Comment Bug 310168 - Replace JavaScript console with the Console2 extension
: Replace JavaScript console with the Console2 extension
Status: RESOLVED DUPLICATE of bug 312962
:
Product: Toolkit Graveyard
Classification: Graveyard
Component: Error Console (show other bugs)
: unspecified
: All All
-- enhancement with 10 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://forums.mozillazine.org/viewtop...
: 323463 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-27 06:46 PDT by Jon Henry
Modified: 2016-06-29 11:02 PDT (History)
14 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image Jon Henry 2005-09-27 06:46:50 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20050926 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20050926 Firefox/1.4

Henrik Gemal recently made me aware of an extension called Console 2 (Console
Squared) that replaces Firefox's JavaScript console and fixes some of the
oldest, most common complaints about the feature. You can find details about the
extension in this Mozillazine thread:
http://forums.mozillazine.org/viewtopic.php?t=318102

The extension seems to fix 18 different reported JS console bugs, including dupe
filtering, only showing certain types of errors (JS, CSS, XML, chrome or
content), allowing the user to search and allowing toolbar customization. It
also changes the obselete name "JavaScript Console" to the more appropriate
"Error Console".

Rather than reinventing the wheel, I am proposing that Firefox replace its JS
Console wholesale with this extension. The current console is a usability
nightmare if you don't clean errors frequently, and this extension takes care of
nearly all of them. If Firefox is going to insist on bundling the console by
default, it could at least be made usable by upgrading to this extension.

Reproducible: Always

Steps to Reproduce:
Comment 1 User image Hixie (not reading bugmail) 2005-09-27 08:58:42 PDT
Would be nice to have this in Firefox 2.0 (probably too late for the 1.5 train).
Comment 2 User image Mike Beltzner [:beltzner, not reading bugmail] 2005-10-24 10:49:29 PDT
Console2 seems like a great functional improvement over console, and I'd also endorse it for Firefox 2. I'd also suggest looking at some of the suggested improvements from bug 312962 which have to do with improving the use of space and alignment within the content area of the console itself.
Comment 3 User image Mike Connor [:mconnor] 2005-11-15 09:56:10 PST
We want to use parts of this extension as we're redesigning the error console, but not necessarily a wholesale change.  Duping to the redesign bug.

*** This bug has been marked as a duplicate of 312962 ***
Comment 4 User image Jesse Ruderman 2006-01-14 17:55:06 PST
*** Bug 323463 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.