Closed Bug 310187 Opened 19 years ago Closed 19 years ago

Bookmarks toolbar has lost all functionality

Categories

(Firefox :: Bookmarks & History, defect)

defect
Not set
major

Tracking

()

VERIFIED FIXED

People

(Reporter: crayolakiddy, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050926 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050927 Firefox/1.6a1 ID:2005092707

Just downloaded the latest 1.6a1 nightly - bookmarks toolbar, although still
showing the icons, has lost all functionality - no highlity, rightt-click
options or the ability to open bookmarks from toolbar at all. 

Reproducible: Always

Actual Results:  
Nothing at all

Expected Results:  
right-click options should display, should be able to open bookmarks from
toolbar, should be a highlight when I hover...

The problem occurs under all themes and with a new profile
-> NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
2005092705 build worked ok. That narrows it down just about as close as
possible. That means it's somewhere between bzbarsky at 6:23pdt and neil at 5:01pdt.

That would mean it's one of these check-ins:

Back out part of patch for bug 155507 to fix bug 310100
Supplementary patch to bug 305384
Bug 94687
Bug 309641 
Blocks: 309452
I have a feeling this was either caused by some of Mano's toolbar fix check-ins
during this period, or Dorando's fix for dragging tabs into the tabbar.
Seeing this shitty bug on my fx under mac.:(

Anybody on linux to confirm and move OS and hardware to ALL ?
OS: Windows XP → All
Hardware: PC → All
This was caused by the checkin for bug 94687.
Blocks: 94687
No longer blocks: 309452
Looks like mousethrough broke.
*** Bug 310275 has been marked as a duplicate of this bug. ***
*** Bug 310320 has been marked as a duplicate of this bug. ***
Version: unspecified → Trunk
*** Bug 310383 has been marked as a duplicate of this bug. ***
*** Bug 310356 has been marked as a duplicate of this bug. ***
*** Bug 310396 has been marked as a duplicate of this bug. ***
Flags: blocking1.9a1?
Blocks: 310485
No longer blocks: 310485
submitted a patch that reorders the bookmarks toolbar stack to restore basic
functionality by moving bookmark toolbar buttons to the top layer.  Doing this
renders the overflow bookmarks layer (chevron) non-clickable.  Ultimately it
will need to be backed out when mousethrough is fixed.	The the stack logic
requires the overflow bar to be on top and Mousethrough=always should let
clicks through to the buttons below.
could this be related to bug 66192?  Another case of non-functioning
mousethrough.  There's a fix patch that appears never to have been committed.
Backed out patch from bug 94687.
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
*** Bug 310504 has been marked as a duplicate of this bug. ***
Flags: blocking1.9a1?
*** Bug 310529 has been marked as a duplicate of this bug. ***
Verified FIXED using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1)
Gecko/20050930 Firefox/1.6a1
Status: RESOLVED → VERIFIED
This seems once again broken with 
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051004 Firefox/1.6a1
 .
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
WFM

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051004
Firefox/1.6 ID:2005100406
WFM on the nightly and the latest: Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv:1.9a1) Gecko/20051004 Firefox/1.6a1 ID:2005100413
seems to be a different issue, resolving this again, sorry!
Status: REOPENED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → FIXED
back to verified it goes...
Status: RESOLVED → VERIFIED
*** Bug 313481 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: