large bookmark file freezes Firefox UI for 30 seconds

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: Ken Winiecki, Jr., Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

A large bookmark file apparently causes the Firefox UI to freeze for
approximately 30 seconds the first time Bookmarks is selected after startup and
when the position of any bookmark near the beginning of the file on the top
level is changed.

Reproducible: Always

Steps to Reproduce:
1.  2 GHz P4
2.  2500 line bookmark file (475 kB with no icons)
3.  Firefox disk cache setting to 0 kB
4.  start Firefox
5.  click Bookmarks

For additional freezes:

6.  open bookmark manager
7.  choose a bookmark on the top level (not in a subfolder) and near the top of
the display, and move it up or down one position

Actual Results:  
The Firefox UI freezes for about 30 seconds.  Sometimes the opening of new Win2k
windows or starting of Win2k applications is blocked as well, but this is not
predictable.

Expected Results:  
Remained unfrozen.

The Firefox UI does NOT freeze under the following conditions:

1.  subsequent clicks of Bookmarks after the first time after startup
2.  in the bookmark manager, when bookmarks near the bottom of the display or
below the top level (in subfolders) are moved
3.  when the bookmarks sidebar is opened or used (except to move bookmarks as
previously noted)
4.  when the bookmarks file contained significantly fewer entries

It occurs to me that my bookmark file top level is significantly larger than any
of the sublevels (folders), and if the problem were related to the number of
bookmarks per level rather than the total number in the file, that could explain
why manipulating the bookmarks in the subfolders does not (yet) cause a freeze.

Comment 1

12 years ago
Confirming with 2.0 (bookmark file approx 1.8MB)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0 - Build ID: 2006101023

Comment 2

11 years ago
I definitely experience the same problem with my firefox 1.5 and firefox 2.0. This probably occurs for previous firefox versions too.

My bookmark list is long, about 500 kb. It is just a single standard list, nothing fancy.

When I open a firefox browser window, and then click on Bookmarks, I find that firefox will hang for about 5 to 6 seconds or even longer. The bookmarks dropdown list will appear only after this hang time. But, after this delay, there will be no more hanging delays for subsequent access to Bookmarks. That is, as long as the browser window remains open, then clicking on Bookmarks will make the bookmarks dropdown list appear immediately. But, if you open another firefox browser window (that is, start up another firefox browser window), I will experience the same hang time for the first time that Bookmarks is accessed.

Comment 3

11 years ago
I forgot to mention that I experience this on my Winxp home edition OS. But I suspect this probably happens on any Winxp edition.

Comment 4

11 years ago
Confirmed with 2.0 (Bookmark file 120 kb)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.5pre) Gecko/20070710 Firefox/2.0.0.4 Navigator/9.0b2

Perhaps someone can at least explain what syntax in our bookmarks.html file is causing this.  I'd be happy to submit mine for testing.

Comment 5

11 years ago
Issue was resolved for me by locating and removing a bookmark I had made to a html page on our company intranet which was unavailable.  The link was stored a s a file: link in the bookmarks.html file.  Apparently, firefox was searching for that location and the time it was frozen was the time it takes for Windows to timeout the network as unavailable.

Comment 6

11 years ago
marking as dupe of Bug 98682 as per comment #5
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 98682
(Reporter)

Comment 7

11 years ago
Reopening:  this bug is unrelated to the file URLs bug because my bookmarks file has none.

Also, it seems to have become an issue again in 2.0.0.7, at least for OS X.  I had not seen it with releases for XP and OS X from 2.0.0.1 to 2.0.0.6, when it only took about 3 seconds to open the Bookmarks menu the first time per session with my 692 kB bookmarks file.  But now with 2.0.0.7, the beachball spins for 70 (seventy) seconds, and at 100% CPU utilization.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 8

11 years ago
I'm having similar issue. I'm running the latest Firefox version 2.0.0.7 on a Vista Ultimate machine. I have a roaming profile set up in a Windows Active Directory domain; Application Data folder is being redirected to a network share. My bookmark file is 3,828KB. When I try to add/delete bookmarks, Firefox hangs for 30 or so seconds and sometimes the 'Add Bookmark' window won't closeafter a minute or so. To test, I created a new profile on the same location. Everything works ok; adding and deleting profiles fast. Once I copied the old bookmark file to the new profile and run Firefox, it does the same thing again. Seems like Firefox is having problems reading big bookmarks files. 
This is WORKSFORME in Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1b3pre) Gecko/20090107 Shiretoko/3.1b3pre RTSE/1.1.0.20081207 ID:20090107020449

This was probably fixed by moving to places.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.