Didn't get any mail from auto-resolve01

RESOLVED INVALID

Status

()

RESOLVED INVALID
13 years ago
12 years ago

People

(Reporter: ian, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
I didn't get a single e-mail notification from the auto-resolve01 nonsense. I
should have received hundreds, since I watch, amongst many others,
bugs@bengoodger.com, and have my mail settings set to get mail when a comment is
made. The mails didn't get filtered by gmail's spam filter.

I have "The bug is in the unconfirmed state" unchecked in my mail settings,
because I was told it was the source of my getting mails that did not have
comment changes (which is basically all I want to receive). Is that why I didn't
get these mails? If so, is there a way to receive notifications from comment
changes, new attachments, and when I'm added or removed in any capacity,
regardless of the state of the bug?
Hmm, I have all "The bug is in the unconfirmed state" checkboxes unchecked too
and I just realized I don't get ANY notification of new filed UNCO bugs and
possibly no bugmail from their changes either. :(

So, without looking actual code, this would suggest that for UNCO bugs there's
only a yes/no flag. Either you get all bugmail or you don't get any for them.
Other checkboxes only affect non-UNCO bugmail.

Note that emailflags rewrite has changed this somehow. There's bug 289593 open
for issues raised from it.
(In reply to comment #0)
> I have "The bug is in the unconfirmed state" unchecked in my mail settings,
> because I was told it was the source of my getting mails that did not have
> comment changes (which is basically all I want to receive). Is that why I didn't
> get these mails? 

Yes. I don't know who told you that first sentence (and I hope it wasn't me!);
the UNCO checkboxes, when unchecked, suppress mail from UNCO bugs to which you
have the given relationship (as I hope is clear from the name).

> If so, is there a way to receive notifications from comment
> changes, new attachments, and when I'm added or removed in any capacity,
> regardless of the state of the bug?

Sadly, no. That would require the UNCO checkbox to be a column rather than a
row, if you see what I mean. 

If you need more serious filtering, consider enabling all UNCO mail and doing it
client or MTA-side, using the X-Bugzilla-Reason header.

Gerv
(Reporter)

Comment 3

13 years ago
All I want is all mail from people adding comments to bugs (including when they
add comments at the same time as attachments), and notifications of anyone
making a change that would mean I didn't get notifications of future changes.
That's all. I don't see any sane way to do that with GMail filters, but it
really should be possible for Bugzilla to do that for me.

I don't want notifications of dependency chain changes (which I do get at the
moment), nor do I care what state the bugs are in (why on earth does the UNCO
row even exist if it is going to override everything else?).

The above is basically what I had described when the whole bugmail filtering
idea was originally floated, all those years ago.

Is there no way to make this simple request possible? I can't imagine I'm the
only person who wants this, I'd imagine _most_ people would in fact want what I
describe here.
(Reporter)

Comment 4

13 years ago
(Something else I don't really want is notifications that another bug has been
marked as a dupe of a bug -- we only get that today because it is implemented as
a comment change.)
That one you can definitely do with client-side filters - the form of the
comment is pretty unique.

Gerv

Comment 6

12 years ago
Is there anything left to actually do on this one?
Not really. We've determined that Hixie's lack of email in this case was not a bug.

If Hixie would like specific changes to the Bugzilla email preferences system, I'm sure he's able to file a bug requesting them :-)

Gerv
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.