"Space" does not drop down list box - has default behaviour instead

VERIFIED WONTFIX

Status

()

Core
Event Handling
P3
normal
VERIFIED WONTFIX
19 years ago
18 years ago

People

(Reporter: con.hennessy, Assigned: joki (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
In the query page goto the field "Summary:", now use the <tab> key
which I would expect to bring me to the "case-insensitive substring".
It does do this but when I try to use the <space> key to see the other
options, the page is scrolled to the end of the page.

BTW to see the same place (i.e. the "case-insensitive" menu )
simply take the mouse out of teh window and back in again.

Comment 1

19 years ago
this sounds like a joki bug (but maybe also pollmann's bug?)
Assignee: chofmann → joki
Component: other → Event Handling
con.hennessy@mail.com - are you still seeing this problem on recent builds of 
Mozilla?

Gerv
(Reporter)

Comment 3

18 years ago
Yes I still see the same behaviour.
And some more strangeness.. When focus is on the option menu for "Summary:"
and I use either the "Up" or the "Down" key, the option does indeed change
but the page also scrolls !!

Comment 4

18 years ago
Do combos need to set some status on the cursor key event to let it know not to 
propagate up to the root window?

Comment 5

18 years ago
This seems to work correctly in today's build on Linux
This is, I think, merely a case of the space-to-drop-down key binding not being 
implemented yet. The other behaviour you mention is, I think, I known issue.

Rewriting summary, confirming (using M15 (20000418) W95).

Gerv
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: tab keys, and focus → "Space" does not drop down list box - has default behaviour instead

Comment 7

18 years ago
Updating QA Contact.
QA Contact: leger → janc

Comment 8

18 years ago
I assume that pressing the spacebar when a combobox has focus is a Linux 
behavior, because this doesn't do anything on Windows. Mac?
(Reporter)

Comment 9

18 years ago
Well looking at the previous comments I am not so sure that it should not
also be in windows and mac versions.

However I was expecting this behaviour from a UI point of view as it is 
fairly standard behaviour that the space bar shows all the options.
(Assignee)

Comment 10

18 years ago
Well the issue of the page scrolling seems ok again, I think maybe saari fixed 
it.

As for the space opening up a options list I'm unfamiliar with that behavior.  
Doing a quick check on Windows this doesn't occur in IE or Navigator 4.x.  I'm 
going to mark this WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX

Comment 11

18 years ago
Mass update:  changing qacontact to ckritzer@netscape.com
QA Contact: janc → ckritzer

Comment 12

18 years ago
Updating QA Contact.
QA Contact: ckritzer → lorca

Comment 13

18 years ago
VERIFIED.  The arrow up/down issue should also have been fxed a while ago as 
well.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.