bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

cut/paste focus different from keyboard focus ?

RESOLVED INCOMPLETE

Status

Thunderbird
Message Compose Window
RESOLVED INCOMPLETE
13 years ago
10 years ago

People

(Reporter: troy, Assigned: Scott MacGregor)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2008-08-28)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.6

This is for 1.0.2.  Sorry but that's "up to date" on Mandriva 2005
and I can't reproduce it anyway :)

I don't know how I got to this state, but I was editing a reply and 
when I highlighted a to/from line and tried to type a replacement, 
the characters typed went to the main text box.  I tried several times
but it behaved as if keyboard focus was not transfered to the to/from
line.  I found I could use cut/paste, though.

Later when I highlighted text in the main text box and tried to use 
cut/paste (via the right button menu, the edit menu or ctrl-x/v), 
the last to/from line accessed was altered.  I tried several times,
but gave up and retyped the part I was going to move with cut/paste.

It appears that there are two focuses and they were out of synch.  
Not quite mouse and keyboard, through, unless ctrl-x/c/v counts as "mouse".

Reproducible: Couldn't Reproduce

Updated

13 years ago
Blocks: 64451

Comment 1

13 years ago
i've seen a bug like this a number of times (version 1.5 (20051201)) on windows xp with all latest updates.

it happens most frequently when the cursor is moved to the start of a line or changes from one field to another. pasting will occur some other place sometimes, or most times not at all. move the cursor away from the front of a line, paste works great and goes where the typing goes.

one workaround is to insert a space, paste, then delete the space.

NOTE that it is hard to get the insertion point before the first character of the subject line. clicking in the white space between the box and the first character doesn't work like it should.

Comment 2

13 years ago
I'm having simular problem with cut and paste when try to paste the cut 
text at "beginning" of another line. (version 1.5)
QA Contact: message-compose
Reporter, does the issue still occur in the latest supported 2.0.0.x / Shredder trunk nightlies?

(1.5.0.x is now end-of-life and the latest supported 2.0.0.x is 2.0.0.16)
Whiteboard: closeme 2008-08-28
Reporter, does the issue still occur in the latest supported 2.0.0.x / Shredder trunk nightlies?

(1.5.0.x is now end-of-life and the latest supported 2.0.0.x is 2.0.0.16)
RESO INCO per lack of response to the last question(s). If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.