Certain zero-length events (start time = end time) cause other events to not be displayed

VERIFIED DUPLICATE of bug 261890

Status

Calendar
Internal Components
VERIFIED DUPLICATE of bug 261890
12 years ago
12 years ago

People

(Reporter: David Sickmiller, Assigned: shaver)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla Calendar 2005011112-cal - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

I created a zero-length event (start time = end time) to keep track of when I
need to submit a school assignment.  On the day and week views, this event did
not display and also caused other events to not display.

Reproducible: Always

Steps to Reproduce:
This happens every time when the event is on certain days, but is not a problem
when the event is on other days.

1. Create an "innocent bystander" event on 2005-10-07 from 1:30-2:40pm.
2. Create another "innocent bystander" event on 2005-10-06 from 1:30-2:50pm.
3. Confirm that this event displays properly on the day view and week view.
4. Create the problem-causing event on 2005-10-06 from 5:00pm-5:00pm.
5. Confirm none of the three events are displayed on the day view and week view.
6. Using the list above the calendar view, edit the problem-causing event to be
5:00pm-5:05pm.
7. Now all of the event should display properly in the day and week views.
Actual Results:  
Some events were not displayed.

Expected Results:  
All events should be displayed.

Comment 1

12 years ago
Duplicate of bug 261890.  Note that this is already fixed in nightly builds.

*** This bug has been marked as a duplicate of 261890 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.