crash [@ nsTextFrame::PrepareUnicodeText]

RESOLVED WORKSFORME

Status

()

Core
Layout: Text
--
critical
RESOLVED WORKSFORME
12 years ago
7 years ago

People

(Reporter: vlad, Unassigned)

Tracking

({crash})

1.8 Branch
x86
Windows XP
crash
Points:
---
Bug Flags:
blocking1.8b5 -

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Repeatable crash by visiting
http://build-graphs.mozilla.org/graph/rawdata.cgi?tbox=sparky.office.mozilla.org&testname=codesize&days=7
and scrolling up and down while the page is loading.

Talkback ID TB9813334G
(http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB9813334G)

My network is flaky atm so I can't test with a trunk build..
Build ID:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20050927 Firefox/1.4

Takes a little while to reproduce sometimes; it seems to help to load the page
first, and then hit Control-R to force us to reload from cache (and thus draw it
fast), and then drag the scrollbar up and down constantly.. seems to usually
happen when scrolling to the end or near the end.
Severity: normal → major
Flags: blocking1.8b5?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050928
Firefox/1.6a1 ID:2005092805

Also in trunk: TB9828141K
I can't reproduce this under linux, though linux seems to load/render the page
-much- faster (which surprises me); you can scroll to the bottom of the fully
loaded/rendered page in <2 seconds, vs. 4-5 seconds under windows.
This looks to be the same as bug 291176, actually; that bug has a+ for the
branch, it's just waiting for checkin (but is resolved/fixed for the trunk,
meaning it eludes most bugzilla searches, gah).


*** This bug has been marked as a duplicate of 291176 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Comment 5

12 years ago
Incident ID: 9828141
Stack Signature	msvcrt.dll + 0x36fa3 (0x77c16fa3) 5cd17a24
Product ID	FirefoxTrunk
Build ID	2005092707
Trigger Time	2005-09-28 09:48:09.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	msvcrt.dll + (00036fa3)
URL visited	
User Comments	
Since Last Crash	635 sec
Total Uptime	635 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
msvcrt.dll + 0x36fa3 (0x77c16fa3)
nsTextFrame::PrepareUnicodeText 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsTextFrame.cpp,
line 1494]
nsTextFrame::IsTextInSelection 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsTextFrame.cpp,
line 2103]
nsTextFrame::CharacterDataChanged 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsTextFrame.cpp,
line 1211]
nsContainerFrame::Init 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsContainerFrame.cpp,
line 88]
nsStackFrame::GetFrameForPointChild 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/xul/base/src/nsStackFrame.cpp,
line 117]
nsHTMLContainerFrame::Paint 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsHTMLContainerFrame.cpp,
line 79]
nsInlineFrame::RemoveFrame 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsInlineFrame.cpp,
line 227]
nsContainerFrame::Init 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsContainerFrame.cpp,
line 88]
nsFrameManagerBase::UndisplayedMap::RemoveNodesFor 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/base/nsFrameManager.cpp,
line 1694]
nsBlockFrame::PaintChildren 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp,
line 6383]
nsHTMLContainerFrame::Paint 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsHTMLContainerFrame.cpp,
line 79]
nsBlockFrame::PaintTextDecorationLines 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp,
line 6189]
nsContainerFrame::Init 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsContainerFrame.cpp,
line 88]
nsFrameManagerBase::UndisplayedMap::RemoveNodesFor 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/base/nsFrameManager.cpp,
line 1694]
nsBlockFrame::PaintChildren 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp,
line 6398]
nsHTMLContainerFrame::Paint 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsHTMLContainerFrame.cpp,
line 79]
nsBlockFrame::PaintTextDecorationLines 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp,
line 6189]
nsContainerFrame::Init 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsContainerFrame.cpp,
line 88]
nsFrameManagerBase::UndisplayedMap::RemoveNodesFor 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/base/nsFrameManager.cpp,
line 1694]
nsBlockFrame::PaintChildren 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp,
line 6398]
nsHTMLContainerFrame::Paint 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsHTMLContainerFrame.cpp,
line 79]
nsBlockFrame::PaintTextDecorationLines 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsBlockFrame.cpp,
line 6189]
nsContainerFrame::Init 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsContainerFrame.cpp,
line 88]
nsStackFrame::GetFrameForPointChild 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/xul/base/src/nsStackFrame.cpp,
line 117]
nsGenConImageContent::QueryInterface 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/content/base/src/nsGenConImageContent.cpp,
line 75]
CanvasFrame::Destroy 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsHTMLFrame.cpp,
line 224]
PresShell::CharacterDataChanged 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/base/nsPresShell.cpp,
line 5066]
nsView::~nsView 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/view/src/nsView.cpp, line
271]
nsViewManager::RenderViews 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/view/src/nsViewManager.cpp,
line 1350]
ConvertNativeRegionToAppRegion 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/view/src/nsViewManager.cpp,
line 748]
IsViewVisible 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/view/src/nsViewManager.cpp,
line 424]
nsView::GetDimensions 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/view/src/nsView.h, line 256]
nsIView::CreateWidget 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/view/src/nsView.cpp, line
681]
nsWindow::~nsWindow 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/widget/src/windows/nsWindow.cpp,
line 830]
nsZLevelEvent::nsZLevelEvent  [../../../dist/include/widget/nsGUIEvent.h, line 533]
nsWindow::DispatchWindowEvent 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/widget/src/windows/nsWindow.cpp,
line 1085]
USER32.dll + 0x8709 (0x77d18709)
USER32.dll + 0x87eb (0x77d187eb)
USER32.dll + 0xb368 (0x77d1b368)
USER32.dll + 0xb3b4 (0x77d1b3b4)
ntdll.dll + 0xeae3 (0x7c90eae3)
IsWin2k 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/widget/src/windows/nsWindow.cpp,
line 268]
nsScrollPortView::Scroll 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/view/src/nsScrollPortView.cpp,
line 549]
nsScrollPortView::ScrollToImpl 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/view/src/nsScrollPortView.cpp,
line 656]
nsScrollPortView::ScrollTo 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/view/src/nsScrollPortView.cpp,
line 312]
nsGfxScrollFrameInner::QueryInterface 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/generic/nsGfxScrollFrame.cpp,
line 1379]
PresShell::CompleteMove 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/base/nsPresShell.cpp,
line 3255]
nsDocument::DispatchContentLoadedEvents 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/content/base/src/nsDocument.cpp,
line 2167]
IsScriptEnabled 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/content/html/document/src/nsHTMLContentSink.cpp,
line 1995]
CNavDTD::BuildModel 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/parser/htmlparser/src/CNavDTD.cpp,
line 464]
Status: RESOLVED → REOPENED
Depends on: 291176
Resolution: DUPLICATE → ---
Summary: crash in nsTextFrame::PrepareUnicodeText → crash [@ nsTextFrame::PrepareUnicodeText]

Updated

12 years ago
Severity: major → critical
Keywords: crash

Comment 6

12 years ago
not anywhere near the topcrash list (#477 on the list)
Flags: blocking1.8b5? → blocking1.8b5-

Comment 7

12 years ago
I think I just ran into this one w/ FF1.5b1 on Win32. Was loading two large
(10MB+) ASCII files in two tabs at once. --> TB10251211Y
WFM on Windows Vista.  The text frame code has seen plenty of churn since 2005 so I don't think the stack traces are still useful.
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago8 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsTextFrame::PrepareUnicodeText]
You need to log in before you can comment on or make changes to this bug.