The default bug view has changed. See this FAQ.

More correct descriptive button and title text for sound notification settings ("Preview Sound"?)

RESOLVED FIXED in Thunderbird 11.0

Status

Thunderbird
Preferences
--
trivial
RESOLVED FIXED
12 years ago
5 years ago

People

(Reporter: Age Bosma, Unassigned)

Tracking

Trunk
Thunderbird 11.0

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: ui-polish)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.12) Gecko/20050919 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.12) Gecko/20050919 Firefox/1.0.7

Just some minor tweaks...

In the new Options dialog of Thunderbird 1.5 (beta 1) in the section "General -
When new messages arrive" the "Advanced..." button only applies to selecting a
specific sound or using the default one. "Advanced..." as the button text seems
to be a bit much in this context. What about changing it to "Sound Settings...",
like the text style of the button underneath it ("Connection Settings...").

Also, after you clicked on the "Advanced..." button, the text in the titlebar of
the new dialog is completely different ("New Mail Sound"). The dialog titlebar
text should reflect it's position a bit more. If the text of the button is going
to be changed to "Sound Settings" than this should be in the titlebar as well,
again like the "Connection Settings".

Furthermore, if you are in the "New Mail Sound" dialog, the "Preview Sound"
button location and text should be changed. How can you preVIEW a sound? ;-)
Something like "Play Sound" or "Test Sound" would make more sense.
The location of the button also implies that it only applies to a custom sound
while this is not the case.

Reproducible: Always

Steps to Reproduce:

Updated

12 years ago
OS: Windows XP → All
Hardware: PC → All
I'm not sure why there's a seperate dialog for this at all. While I appreciate
the desire to reduce clutter in options, the pop up dialog doesn't really make
anything easier, it just hides away some UI. I'm tempted to suggest:

.- When new messages arrive: ---------------------------------------.
|  [x] Show an alert                                                |
|  [x] Play a sound                                                 |
|        (o) Default system sound for new mail                      |
|        ( ) Use the following sound file                           |
|            [                                ] [Browse...] [Play]  |
|                                                                   |
'-------------------------------------------------------------------'

Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: ui-polish
Target Milestone: --- → Future
Version: unspecified → Trunk
(Reporter)

Comment 2

12 years ago
I think it's better to keep the separate dialog. Most people will probably never
change the default sound of the notification. Therefor it will only clutter the
options unnecessary with something most people won't even use.
In addition, I think the button for the extra sound selection dialog should only
be activated when the sound notification option is actually enabled, something
which I beleave isn't the case right now (I haven't got Thunderbird available at
the moment so don't shoot me if I'm wrong).
(Reporter)

Comment 3

12 years ago
Is there any chance this bug can be fixed before the 1.5 final? It would be a pity to see this, relatively easy to fix, issues not making it for the next major release ;-) With issues like these I feel bad about not being a hacker myself, I'd love to be able to help out a bit, especially with minor things like these.

Comment 4

12 years ago
I would suggest it would be nice to have something like in Apple Mail. They manage everything using one combo what is really nice. In the combo box is "None" as the first item, then a list of system sounds, and the last item is Add/Remove. I think we might be able to display None, separator, then list of system sounds (if OS supports that), separator, list of user's, separator, Add/Delete which show some stupid dialog where you can do nothing else then add/delete custom sounds. What about testing? It plays sound when you select it in the combo box. This might not work for windows users which would require some play button, but in Mac world it's perfectly ok.

I would also imagine this kind of change for Connection Settings, and maybe some more. It's all about simplyfing UI, opening less dialogs... Hope my thoughs helps in the future directions. 

Comment 5

11 years ago
*** Bug 354160 has been marked as a duplicate of this bug. ***

Comment 6

11 years ago
The 'Advanced' button now has two sets of advanced options: the sound configuration is as before, but now the notification alert can be configured.
The dialog title is now "Customize New Mail Notifications."  Relabeling the button still would be good, just because the General page has an Advanced button while the Advanced page has a General tab.  Maybe "Configure..." for a button label.

Updated

9 years ago
Assignee: mscott → nobody

Comment 7

5 years ago
First merge on the Mercurial repository had the exact appearance from comment 1, which was one of the solutions that comment 0 was talking. Closing.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.