svgtetris does not work on trunk

RESOLVED FIXED

Status

()

Core
SVG
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Vidar Haarr (not reading bugmail), Assigned: tor)

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
I was testing some layout-wide cleanup changes and noticed that svgtetris
doesn't work on trunk. The bricks do fall in the script, because you lose the
game after some time, but nothing is refreshed/painted after the initial paint.

I have no idea if this is expected behavior or not, since I do not know SVG I
can't read if from the SVG source (maybe it used some workaround or whatever
that doesn't work anymore and isn't supposed to either), and thus I'm filing the
bug as UNCONFIRMED.
(Assignee)

Comment 1

12 years ago
Created attachment 197723 [details] [diff] [review]
fix path update logic for nonmarkable objects
Assignee: general → tor
Status: UNCONFIRMED → ASSIGNED
Attachment #197723 - Flags: review?(scootermorris)

Comment 2

12 years ago
Comment on attachment 197723 [details] [diff] [review]
fix path update logic for nonmarkable objects

Oops!
Attachment #197723 - Flags: review?(scootermorris) → review+
(Assignee)

Comment 3

12 years ago
Checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

12 years ago
Note that the bug summary says "trunk", but I did not actually check the 1.8
branch. It might be broken there, too (for all I know.)
You need to log in before you can comment on or make changes to this bug.