[BEOS] bookmark toolbar: bookmarks do not work when clicked.

RESOLVED DUPLICATE of bug 310187

Status

()

Firefox
Toolbars and Customization
--
major
RESOLVED DUPLICATE of bug 310187
12 years ago
12 years ago

People

(Reporter: Doug Shelton, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (BeOS; U; BeOS BePC; en-US; rv:1.9a1) Gecko/20050925 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (BeOS; U; BeOS BePC; en-US; rv:1.9a1) Gecko/20050925 Firefox/1.6a1

When building from CVS (with required bookmarks.js workaround for BeOS),
bookmarks on the toolbar appear, but do not work.  Problem happened after CVS
update; can be isolated to CVS changes between 2005-09-22 and 2005-09-28.

I've eliminated changes to nsWindow by backing out to revisions that worked
prior to the 2005-09-28 CVS update.

Reproducible: Always

Steps to Reproduce:
1. Pull a clean tree from trunk CVS
2. apply workaround from bug 104729 (required for BeOS bookmarks to be visible)
3. build firefox
4. run browser
5. click any bookmark on bookmark toolbar.

Actual Results:  
clicking on bookmarks toolbar does nothing.

Expected Results:  
opened the page or folder drop-down associated with the bookmark.
(Reporter)

Comment 1

12 years ago
Created attachment 197749 [details]
list of cvs updates

attached list of CVS updates made.  bookmark toolbar became non-functional
after this update.
(Reporter)

Updated

12 years ago
Summary: [BEOS] bookmark toolbar: bookmarks do not work when clicked. → [BEOS] bookmark toolbar: bookmarks do not work when clicked.
(Reporter)

Updated

12 years ago
Blocks: 266252
Any reason to believe it's anything other than bug 310187?
(Reporter)

Comment 3

12 years ago
in working with DOM inspector, it appears that somehow the bookmarks toolbar
overflow items is on top of the bookmarks and intercepting the mouse clicks.  If
you use the DOM inspector to inspect the browser window, select the "find a node
by clicking on it" button, then click on the bookmarks toolbar, the DOM
inspector moves always to bookmarks-toolbar-overflow-items node.  In working
versions, the inspector moves to the node associated with the bookmark.  

Comment 4

12 years ago
This is a dupe, and occurs on all OSes, not just BEOS.

*** This bug has been marked as a duplicate of 310187 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.