Closing of tabs causes another tab to not render

RESOLVED DUPLICATE of bug 310595

Status

()

Firefox
Tabbed Browser
--
major
RESOLVED DUPLICATE of bug 310595
13 years ago
13 years ago

People

(Reporter: Ava3ar, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20050928 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20050928 Firefox/1.6a1

If you goto a website and then open a link in a new tab

close this tab, either the new first (current) tab will be now completlly blank

or if you have more than 1 tab open, the first/last tab will be blank, going to
this tab and then to another will cause all tabs to be blank, opeining a new tab
(blank or from external link) will render properlly

Reproducible: Always

Steps to Reproduce:
1.open firefox, 
2.open a new tab (from link or external link)
3.close either tab, top tab will now be blank
3a. or if more than one tab is open at the time, first/last tab will be blank,
visiteing it will cause all tabs there after to go blank

4. opening a new tab (from external or blank) will render properlly, but closing
the defunct tab/s can cause this tab to turn blank

Actual Results:  
tabs become blank, even if refreshed and page says loaded, (even source shows
nothing)

Expected Results:  
tabs to render properlly (source to show on tabs if  applicable)

Comment 1

13 years ago
WFM

Comment 2

13 years ago
Do you see this when you start Firefox with ./firefox -safe-mode?
(firefox/firefox-bin must not be running when you start in safe mode.)
When did this regress?
Can you see it in yesterday's trunk build?
It might be a regression from the last patch from bug 281709.
(Reporter)

Comment 4

13 years ago
(In reply to comment #2)
> Do you see this when you start Firefox with ./firefox -safe-mode?
> (firefox/firefox-bin must not be running when you start in safe mode.)

might be becasue im on gentoo, but i cant run firefox-bin, i get the xpcom_core
error
(Reporter)

Comment 5

13 years ago
(In reply to comment #3)
> When did this regress?
> Can you see it in yesterday's trunk build?
> It might be a regression from the last patch from bug 281709.

just updated, and problem still exists
(Reporter)

Comment 6

13 years ago
k bit extra

say you have tabs

1 2 3

going to 1 from 2 = non-render goes blank
going to 2 from 1 = normal
going from 1 to 3 = normal, but now you cant go to 2
going 3 to 2 = non-render

going backwards or closing a tab ahead of your current causes it to non-render,
closing a tab thats behind

1 2 3
on 3 cosing 2/1 okay can render normal from there, but you cant go back to 2 if
you closed 1

closing a tab ahead, 1 2 3, on 2 close 3 = non-render of all, until new tab is
opened from exterrnal/new tab

Comment 7

13 years ago
Reporter, you have still yet to test this in safe-mode. This could very well be
an extension-related problem that continues to appear because you are using the
same profile. ./firefox -safe-mode

Comment 8

13 years ago
This sounds like what I am seeing in Seamonkey - bug 310595.
(Reporter)

Comment 9

13 years ago
(In reply to comment #7)
> Reporter, you have still yet to test this in safe-mode. This could very well be
> an extension-related problem that continues to appear because you are using the
> same profile. ./firefox -safe-mode

just run in safe, and new profile, and problem still exists
(Reporter)

Comment 10

13 years ago
(In reply to comment #8)
> This sounds like what I am seeing in Seamonkey - bug 310595.
> 

yeah thats the same (as linked from that bug to this)
This should be fixed in tomorrow's trunk build, because of the back-out of bug
281709's patch.
Depends on: 310483

Comment 12

13 years ago

*** This bug has been marked as a duplicate of 310595 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.