Closed Bug 31039 Opened 20 years ago Closed 20 years ago

Shouldn't use label for accesskey

Categories

(Core :: XUL, defect, P2)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: rchen, Assigned: bugs)

References

Details

(Whiteboard: [PDT+] w/b minus on 03/09)

In navigatorOverlay.xul, menu "Send Link" and "Edit Page" use labels for 
accesskey, which causes localization problem. Please create the accesskey in DTD 
like for "Print setup" "Print Preview"...
 
<menuitem id="menu_sendPage"  observes="cmd_sendPage"/>
	      <menuitem accesskey="&sendLinkCmd.label;"  // This is wrong
observes="Browser:SendLink"/>
	      <menuitem accesskey="&editPageCmd.label;"  // This is wrong
observes="Browser:EditPage" />
	      <menuseparator/>
	      <menuitem accesskey="&printSetupCmd.accesskey;"  // This is right
observes="Browser:PrintSetup"/>
	      <menuitem accesskey="&printPreviewCmd.accesskey;" // This is right
observes="Browser:PrintPreview"/>
Need to be fixed for Japanese beta1
Keywords: beta1
Because label will be localized but not accesskey, we need to separate accesskey 
from label.
General can be a overlooked. Changing to XP Toolkit.  If this belongs to others 
please reassign.  Browser 
Assignee: davidm → pinkerton
Component: Browser-General → XP Toolkit/Widgets: Menus
QA Contact: asadotzler → sairuh
->teruko's group for qa.
QA Contact: sairuh → teruko
Putting on PDT+ radar for beta1.  Must fix by 03/09.
Whiteboard: [PDT+] w/b minus on 03/09
must fix or else what?
Status: NEW → ASSIGNED
if this is just mucking with dtd and xul, then this is not an xpmenu bug or an 
xptoolkit issue. please correct me if i'm wrong. 
Assignee: pinkerton → ben
Status: ASSIGNED → NEW
You are right. This is a simple and low risk fix. 

This is a bug for US build, too. 

"Send Link" uses the same letter "s" as "Save Page As" and "Edit page" uses the 
same letter "e" as "New". You can't to use one letter for two different menu 
items. 

Priority: P3 → P2
Target Milestone: M14
I'll fix this but I'm having a hard time understanding how in the hell this 
became PDT+. 
Status: NEW → ASSIGNED
fixed. 
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
hate to bring this up, but have you looked at the menu with your change? instead

of "Send Link" and "Edit Page", it just says "i" and "d"



This should never have been marked PDT+...

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I would say it would be nice to have it fixed. This bug is so obvious to the 
users and the fix is so simple.
*** Bug 31192 has been marked as a duplicate of this bug. ***
whups, back to me :-)
QA Contact: teruko → sairuh
d'oh.

okay. I had a weird file system error before checking this in. give me 10 
minutes to sort this out.

BAM

BAM
Status: REOPENED → ASSIGNED
ok. fixed. 
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
looks fine on winNT [2000.03.10.09, opt comm].

still waiting on the linux and mac bits, la la la...
verif on linux [opt comm] and macOS [opt non-comm], 2000.03.10.1x.
Status: RESOLVED → VERIFIED
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: bugzilla → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.