Remove keyboard and mouse shortcuts for other browsers from docs

RESOLVED FIXED in Firefox1.5

Status

P2
normal
RESOLVED FIXED
13 years ago
3 years ago

People

(Reporter: mano, Assigned: jwalden+fxhelp)

Tracking

({fixed1.8, late-l10n})

1.5.0.x Branch
Firefox1.5
fixed1.8, late-l10n

Details

Attachments

(1 attachment, 1 obsolete attachment)

The "Keyboard Shortcuts" document has wrong entries for MacIE.
Status: NEW → ASSIGNED
Priority: -- → P2
Target Milestone: --- → Firefox1.5
(Assignee)

Comment 2

13 years ago
I think it's time to bite the bullet and remove the list of keyboard and mouse
shortcuts for other browsers.  They're often inaccurate (see the bug for
inaccurate Opera shortcuts, as well as here - there hasn't even been a Mac IE
for years, and I think the Opera shortcuts have been wrong since about day 1),
they provide very little useful information to the user in the context of using
Firefox, and they impose a pretty huge burden on Help localizers (shortcuts
can't be paraphrased if time's running short).

I think we want to remove the lists of keyboard/mouse shortcuts for other
browsers and appropriately amend the flavor text for each document.  Steffen, do
you agree with me here, or do you have any better suggestions that would still
be informative yet not be a real pain for both us and localizers?  (One
possibility that comes to mind is moving extra documentation to mozilla.org,
although that may not help localizers much.)  I don't know how much longer we
have to get fixes in for 1.5, so we need to decide this now.

Comment 3

13 years ago
Comparing keyboard and mouse shortcuts with other popular browsers is nice if
you want to advertize Firefox on a webpage by explaining that users don't have
to learn new shortcuts, but that Firefox is more accessible because it offers
more of them.
I don't think that this comparison is needed in the installed product. I guess
new quickly find out whether other browsers' shortcuts work by either trying
them out or by looking in the menus, then by looking at our docs if there are
any new shortcuts they might be interested in. And the tables would be less
complex if we remove the IE and Opera shortcuts. So let's do it.
(Assignee)

Comment 4

13 years ago
Created attachment 198961 [details] [diff] [review]
Remove the info for other browsers, lightly tweak flavor text
Assignee: bugs.mano → jwalden+fxhelp
Attachment #197831 - Attachment is obsolete: true
Attachment #198961 - Flags: review?(steffen.wilberg)
(Assignee)

Updated

13 years ago
OS: MacOS X → All
Hardware: Macintosh → All
Summary: "Keyboard Shortcuts" document has wrong entries for MacIE → Remove keyboard and mouse shortcuts for other browsers from docs

Comment 5

13 years ago
Comment on attachment 198961 [details] [diff] [review]
Remove the info for other browsers, lightly tweak flavor text

>Index: browser/locales/en-US/chrome/help/mouse_shortcuts.xhtml
>+  <span class="unix">The shortcuts are for Windows, but most
>+  of the &brandShortName; shortcuts should work on Linux too.</span></p>
Please remove that sentence. Our own shortcut list has to be correct on all
platforms.

>-<table border="1" width="100%">
>+<table border="1">
>   <thead>
>     <tr>
>       <th>Command</th>
>       <th>&brandShortName;</th>
Please replace &brandShortName; by "Shortcut".
>-      <th>Internet Explorer</th>
>-      <th>Opera</th>

>Index: browser/locales/en-US/chrome/help/shortcuts.xhtml
>+<table border="1">
>   <thead>
>     <tr>
>       <th>Command</th>
>       <th>&brandShortName;</th>
Same here.
>-      <th>Internet Explorer</th>
>-      <th>Opera</th>

r=me with that.
Attachment #198961 - Flags: review?(steffen.wilberg)
Attachment #198961 - Flags: review+
Attachment #198961 - Flags: approval1.8rc1?

Updated

13 years ago
Attachment #197831 - Flags: review?(jwalden+fxhelp)

Updated

13 years ago
Keywords: late-l10n
(Assignee)

Comment 6

13 years ago
*** Bug 291877 has been marked as a duplicate of this bug. ***

Comment 7

13 years ago
Can't we fix the mac help without removing this very useful information for our
Windows users? 

Updated

13 years ago
Attachment #198961 - Flags: approval1.8rc1? → approval1.8rc1-
(Assignee)

Comment 8

13 years ago
(In reply to comment #7)
> Can't we fix the mac help without removing this very useful information for
> our Windows users? 

Asa, I don't believe it really is all that useful.

How does knowing that IE's shortcut for focusing the location bar is Alt+D help
you use Firefox?  Knowing that Firefox's shortcuts are Ctrl+L and Alt+D is very
helpful, but that has nothing to do with knowing IE's shortcuts to do the same;
you can most certainly know one without knowing the other.  I also argue that
offering both will confuse some number of users who accidentally learn the wrong
shortcut when reading help documentation to learn keyboard shortcuts.  In a user
community of 100 million this is going to happen.

Another problem with listing keyboard shortcuts for other browsers is that such
lists will be wrong.  The Help maintainers are experts at using Firefox; we are
not expert at using Opera, IE, or Netscape, and we do a poor job of pretending
we are.  (As a second example, our Opera shortcut list is almost completely
inaccurate, and it's been that way since the Fire(bird) Help project started.) 
There's a non-zero cost to maintaining a shortcut list for other browsers, and I
believe the costs outweigh the rewards.

Shortcut lists for other browsers will also become dated as new versions of the
other browsers are released.  Not having a tab-supporting IE makes tab-related
shortcuts for it easy to list, but when IE7 comes out we'd have to update the
list, and we'd have to note that such shortcuts are only useful in IE7.

Finally, you can use IE's shortcut list to determine how compatible Firefox's
keyboard shortcuts are with IE, but that's about it.  This information has some
value if you're considering switching browsers, but if you're already using
Firefox you're less likely to need the information.  Also, it's not clear to me
how being able to "quantify" shortcut compatibility with another browser is
actually helpful to the average user.  Shortcut compatibility in specific cases
is what matters, and we're already quite set there (as I show in the next
paragraph).

If you still disagree with me, be certain to note that Firefox's shortcuts are
*incredibly* compatible with IE.  I went through the current list in help docs
in CVS (which likely isn't complete because XBL-specified shortcuts aren't easy
to find but is as complete as you'll get), and I found only two places that
diverge in the whole shortcut list.  First, IE supports F4 to focus the location
bar, and Firefox doesn't (but we do support IE's F6 and Ctrl+D shortcuts). 
Second, IE uses Del to remove autocomplete entries, while we use Shift+Del. 
These are the *only* shortcuts IE supports that Firefox doesn't, to the best of
our knowledge.  Are these two shortcuts really worth cluttering the screen with
a lot of otherwise useless information?

As a compromise I think including a link to an online version with shortcut
comparisons with other browsers is bearable (although, given my investigations
in the last paragraph, not ideal).  Such a list doesn't have to be static like
the built-in list, and download size isn't as much a concern as it is in the
actual Firefox download itself.  It will also be difficult to maintain, but if
we feel so strongly about providing this information then the maintenance costs
should be irrelevant.
(Assignee)

Comment 9

13 years ago
Comment on attachment 198961 [details] [diff] [review]
Remove the info for other browsers, lightly tweak flavor text

Asa, please see the previous comment for further rationale for why we'd like to
do this.
Attachment #198961 - Flags: approval1.8rc1- → approval1.8rc1?

Comment 10

13 years ago
Comment on attachment 198961 [details] [diff] [review]
Remove the info for other browsers, lightly tweak flavor text

OK. Thanks for taking the time to put together that post. a=asa for branch
checkin.
Attachment #198961 - Flags: approval1.8rc1? → approval1.8rc1+
(Assignee)

Comment 11

13 years ago
Patch checked in (with requested changes) to both branch and trunk.

(Regarding the requested changes, while making the patch I definitely thought
about the "Shortcut" change but forgot to make it.  I also debated removing the
sentence on Linux compatibility but thought it might possibly have some truth to
it, so I left it out of laziness.  I just tested the shortcuts, and they do all
seem to work properly on Linux, so it looks like no harm done axing the sentence.)
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.