Stop button should not stop animated GIFs

RESOLVED WONTFIX

Status

()

Firefox
Toolbars and Customization
RESOLVED WONTFIX
13 years ago
8 years ago

People

(Reporter: Ido Beeri, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

This thing has annoyed me ever since I started using Mozilla:
When you click on Stop while it's an enabled button (AKA when the page is
loading), the page stops loading, but also all animated GIFs are stopped.
When you click on Stop when it's disabled, nothing happens at all.

So the way I see it there are 2 real options:
1. Stop button should never stop animated GIFs.
2. Stop button should always stop animated GIFs (even when the page is not
currently loading).

Because, this "you can only stop animated GIFs while the page is loading" thing
doesn't make a whole lot of sense to me.

Reproducible: Always

Steps to Reproduce:

Comment 1

13 years ago
Bug 256062 is basically the flip-side of this: it asks for stop to always stop
gifs.  So this could be a supe, but if stop should never stop gifs, it's not.

This bug is also toolbars, I guess.  All related bugs are.
Component: General → Toolbars
QA Contact: general → toolbars

Comment 2

13 years ago
Also see core bug 21623
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20050929
Firefox/1.4 ID:2005092901

It will only stop animated gifs that aren't completely loaded.
The ones that are fully loaded keep playing.

I guess that makes this bug INVA
(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20050929
> Firefox/1.4 ID:2005092901
> 
> It will only stop animated gifs that aren't completely loaded.
> The ones that are fully loaded keep playing.
> 
> I guess that makes this bug INVA

No you are wrong. It will stop all gifs (also those which are completely loaded)
if the html page isn't completely loaded.
(In reply to comment #4)
> (In reply to comment #3)
> > Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20050929
> > Firefox/1.4 ID:2005092901
> > 
> > It will only stop animated gifs that aren't completely loaded.
> > The ones that are fully loaded keep playing.
> > 
> > I guess that makes this bug INVA
> 
> No you are wrong. It will stop all gifs (also those which are completely loaded)
> if the html page isn't completely loaded.

Right, in the case I set up the page was fully loaded, just the gifs haden't yet.

Comment 6

11 years ago
This seems to be a carry-over from Netscape 4, where the stop button is always enabled and stops animated GIFs as a "feature." (Basically what Bug 256062 is asking for.)

I feel that the proper solution would be to separate "stop page attempting to load from doing so/finishing" and "stop all the little annoying animations from moving" into two different functions.

Comment 7

8 years ago
(In reply to comment #5)
> (In reply to comment #4)
> > (In reply to comment #3)
> > > Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20050929
> > > Firefox/1.4 ID:2005092901
> > > 
> > > It will only stop animated gifs that aren't completely loaded.
> > > The ones that are fully loaded keep playing.
> > > 
> > > I guess that makes this bug INVA
> > 
> > No you are wrong. It will stop all gifs (also those which are completely loaded)
> > if the html page isn't completely loaded.
> 
> Right, in the case I set up the page was fully loaded, just the gifs haden't yet.

Just one thing I am bit curious about. A page must not be considered as fully loaded unless all the elements (including gifs) are loaded.

Comment 8

8 years ago
The stop button is now disabled when the page is done loading.
While the button is enabled, the page is still loading, so stopping any animations upon clicking stop is reasonable behavior.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.