SB0.2+ will not import a recurring event made from SB0.2

RESOLVED FIXED

Status

RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: mperanelli, Assigned: vlad)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050927 Mozilla Sunbird/0.2+

I can not import a calendar with recuuring events I made with Sunbird 0.2 into
Sunbird 0.2+  The calendar works fine on Sunbird 0.2

I get the following errors:

Error: flushItem DB error: not an error
Source File:
file:///C:/Program%20Files/Mozilla%20Sunbird/components/calStorageCalendar.js
Line: 1446

Error: [Exception... "Component returned failure code: 0x80004005
(NS_ERROR_FAILURE) [calIRecurrenceRule.endDate]"  nsresult: "0x80004005
(NS_ERROR_FAILURE)"  location: "JS frame ::
file:///C:/Program%20Files/Mozilla%20Sunbird/components/calStorageCalendar.js ::
anonymous :: line 1660"  data: no]
Source File:
file:///C:/Program%20Files/Mozilla%20Sunbird/components/calStorageCalendar.js
Line: 1660

Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [calIRecurrenceRule.endDate]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
file:///C:/Program%20Files/Mozilla%20Sunbird/components/calStorageCalendar.js ::
anonymous :: line 1660"  data: no]


Reproducible: Always

Steps to Reproduce:
1.Select a calendar to import the file to
2.Go to file>import
3.select calendar (didn't know how to put the actual calendar on here, but here
is one recurring event, sorry for the long post.)

BEGIN:VCALENDAR
VERSION
 :2.0
PRODID
 :-//Mozilla.org/NONSGML Mozilla Calendar V1.0//EN
BEGIN:VEVENT
UID
 :87a1161c-102c-11da-a930-b1c5527a4522
SUMMARY
 :Name
CATEGORIES
 :Birthday
STATUS
 :CONFIRMED
CLASS
 :PRIVATE
X-MOZILLA-ALARM-DEFAULT-UNITS
 :days
X-MOZILLA-ALARM-DEFAULT-LENGTH
 :1
X
 ;MEMBER=AlarmEmailAddress
 :myemailaddress
X-MOZILLA-RECUR-DEFAULT-UNITS
 :years
RRULE
 :FREQ=YEARLY;INTERVAL=1;BYMONTH=2
DTSTART
 ;VALUE=DATE
 :20060226
DTEND
 ;VALUE=DATE
 :20060227
DTSTAMP
 :20050818T211013Z
LAST-MODIFIED
 :20050909T114907Z
BEGIN:VALARM
TRIGGER
 ;VALUE=DURATION
 :-P1D
END:VALARM
END:VEVENT
END:VCALENDAR
Actual Results:  
After selecting the calendar the window just closes.  Nothing happens.  The
events do not show up on the calendar.

Expected Results:  
The events should have showed up on the calendar.
(Reporter)

Comment 1

13 years ago
Created attachment 197907 [details]
SampleCalendar.ics
(Reporter)

Updated

13 years ago
Attachment #197907 - Attachment description: Sample Calendar → Just found out how to create an attachment. Use the calendar above to reproduce the error.
(Reporter)

Comment 2

13 years ago
Comment on attachment 197907 [details]
SampleCalendar.ics

Just found out how to add an attachment.  Use SampleCalendar.ics to reproduce
the error
Attachment #197907 - Attachment description: Just found out how to create an attachment. Use the calendar above to reproduce the error. → SampleCalendar.ics

Updated

13 years ago
Assignee: mostafah → vladimir
Component: General → Storage provider
QA Contact: general → storage-provider
Created attachment 198349 [details] [diff] [review]
patch v1

I'm a bit surprised that manually creating infinitly recurring events work with
the storage calendar. Somehow, importing them from ics doesn't work, because it
doesn't store the null endDate right. This patch fixes it.
(I think it happens to work, because it sets endDate.nativeTime to null,
instead of endDate itself. The storage provider only storaes the nativetime)
Attachment #198349 - Flags: first-review?(dmose)
Comment on attachment 198349 [details] [diff] [review]
patch v1

r=dmose
Attachment #198349 - Flags: first-review?(dmose) → first-review+
patch checked in
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.