Drag-selecting over Java applet causes drawing issues

RESOLVED INVALID

Status

Camino Graveyard
Plug-ins
RESOLVED INVALID
13 years ago
11 years ago

People

(Reporter: Simon Fraser, Assigned: smichaud)

Tracking

Trunk
PowerPC
Mac OS X

Details

(URL)

(Reporter)

Description

13 years ago
If you select text, starting in the HTML text above an applet, and
drag-selecting over the applet, then the applet redraws oddly; parts of it fail
to redraw correctly, and the applet steals focus from the page. This does not
happen in Firefox.

Steps:
1. Go to http://www.volano.com/webroom.html
2. Click in the first paragraph ("This is a demonstration...") and drag-select
down into the paragraph below the applet ("Visit the Volcano...").
3. Note that the most of the applet disappears.
4. Note also that the selection changes from the "focussed" hilight color to the
inactive grey color as soon as your mouse passes over the applet. This should
not happen.
(Assignee)

Comment 1

13 years ago
I'm not able to reproduce this.  Could someone else give it a try?

I tested with Camino 2005-09-27-04-1.0 and 2005-09-27-08 (the trunk), both of
which include JEP 0.9.4+a.

The applet did occasionally disappear and stay missing.  But usually it went
blank only momentarily, and then only if dragging the mouse caused the page to
scroll (this is normal behavior for the JEP).

I never saw item #4 at all.

I saw exactly what Simon saw, but only the first time I tried (no scrolling
involved, either; the entire applet was within the visible bounds of the window
at all times).  Subsequent times, even after emptying cache and restarting
Camino, produced no vanishing of any of the applet nor wrong coloring of the
highlighted text.

Camino 2005092804 (v1.0a1+)
(Assignee)

Comment 3

13 years ago
I've now figured out how to recreate this problem almost 100% of the time --
first put the focus in either of the applet's two text boxes!

I've no idea what's going on, or whether the problem also happens with other
kinds of plugins.  Even the focus trick doesn't make the problem happen with
Firefox (recent builds).

Does anyone have an example of a non-Java plugin that has one or more text
input boxes?

(Assignee)

Comment 4

13 years ago
The problem (or something like it) also happens in Safari (on OS X 10.3.9, at
least) -- if you first put the focus in one of the applet's text boxes or
change the focus from one box to the other.

This is beginning to look like a Java problem.  I haven't yet done any tests
on OS X 10.4 (or 10.2.8).

My workarounds for the massive number of Cocoa-Carbon-interface bugs must also
(inadvertently) have worked around this one on Firefox :-)

(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 5

13 years ago
I've done a bit more research.

I've now found this problem on OS X 10.4.2 (with Java 1.4.2), using Safari and
Camino, and on OS X 10.2.8 using Camino.  (I'm unable to test Safari on OS X
10.2.8, but I'm quite sure it also has the problem.)

Very interestingly, the problem _doesn't_ happen on OS X 10.4.2, in either
Camino or Safari, if you use Java 5.0/1.5.

The specific trigger differs a bit from OS to OS.  Sometimes having the focus
in either text box is enough (on OS X 10.4.2 and 10.2.8).  Sometimes you need
to change it from one box to the other (especially from the first to the
second) before you test.

Since this problem also happens in Safari, and particularly since it doesn't
appear to happen with Java 1.5 on OS X 10.4.2, this must be a problem with
Apple's JVM -- probably a regression caused by Apple's recent Java updates.

Since Safari is effected, I assume Apple will fix this, eventually.

For that reason, I'm not going to work on it myself :-)

Comment 6

11 years ago
Closing INVALID, since this is apparently a Java issue.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.