Colors of gif files do not match the background color in html.

RESOLVED DUPLICATE of bug 114701

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 114701
12 years ago
12 years ago

People

(Reporter: jan klopper, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

I decided to place two gif files with a colored background on top of a page with
a backkground color. Both the images have the same color used for their
backgrounds as the html.

But both images show a slight difference in colors compared to the html background.

Sampling the colors from the website with TheGimp 1.3 indeed gives me a
different color as the images give when opened directly in the gimp. But it also
give a different color for the html generated background.

On windows this works wthout any problems in FF 1.0.7 and 1.5B
On linux (suse 9.0 this works in Opera 8.01 and Konqueror)

Only firefox 1.5B (and maybe other foxes) give a different color as they should.



Reproducible: Always

Steps to Reproduce:
1. Create Div with background-color #F0F0F0
2. Create a gif image with Clored Dot in center, and background of #F0F0F
3. Place image inside div, and notive the gif's background is more green than it
should.

Actual Results:  
wrong colors. :(

Expected Results:  
Drawn the colors as stated in the html/gif

Comment 1

12 years ago
I think it's a duplicate of bug 114701 (see bug 152192 also).
Reporter, please mark it as dup of 114701 if you agree.
 
Summary: Colors of gif files do not match the background color in html. → Colors of gif files do not match the background color in html.

Comment 2

12 years ago
Bug 14147 is related with this
(Reporter)

Comment 3

12 years ago
This is indeed a 16 bits color bug.

Im not too sure if it is because the web-safe colors are different for the gif -renderer, and the css renderer, but the same high color, share, gets transformed into two different 16 bit colors it seems.

*** This bug has been marked as a duplicate of 114701 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.