Bad Link for adding LEO as search engine on http://www.mozilla.org/products/firefox/central#central-engines

RESOLVED DUPLICATE of bug 310092

Status

www.mozilla.org
General
RESOLVED DUPLICATE of bug 310092
13 years ago
6 years ago

People

(Reporter: Simon Spielmann, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.12) Gecko/20050919 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.12) Gecko/20050919 Firefox/1.0.7

The link to add LEO as new search engine for firefox on the page
http://www.mozilla.org/products/firefox/central#central-engines is invalid.
Adding it directly from the mycroft site works.

Reproducible: Always

Steps to Reproduce:
1. visit http://www.mozilla.org/products/firefox/central#central-engines
2. click 'Leo'-Link to add this new "search-engine" to firefox


Actual Results:  
leo isn't added because the URL für leo.src is invalid

Expected Results:  
having leo as new search-engine in firefox

I provided a patch for the web page - mainly the javascript changed. It was
copied from mycroft.org

Index: mozilla-org/html/products/firefox/central.html
===================================================================
RCS file: /cvsroot/mozilla-org/html/products/firefox/central.html,v
retrieving revision 1.24
diff -u -r1.24 central.html
--- mozilla-org/html/products/firefox/central.html	26 Sep 2005 00:20:34 -0000	1.24
+++ mozilla-org/html/products/firefox/central.html	30 Sep 2005 18:32:30 -0000
@@ -103,19 +103,24 @@
     location.href="http://mycroft.mozdev.org/error.html"; //hack for
DOM-incompatible browsers
   }
 }
-function addEngine(name,ext,cat)
+function addEngine(name,ext,cat,type)
 {
   if ((typeof window.sidebar == "object") && (typeof
   window.sidebar.addSearchEngine == "function"))
   {
     //cat="Web";
     //cat=prompt("In what category should this engine be installed?","Web")
-    window.sidebar.addSearchEngine(
-      "http://mycroft.mozdev.org/plugins/"+name+".src",
-      "http://mycroft.mozdev.org/plugins/"+name+"."+ext,
-      name,
-      cat );
-  }
+    if (type!="0") {      window.sidebar.addSearchEngine(
+        "http://mycroft.mozdev.org/nowrapper/submit-install.php/v/" + type +
"/" + name + ".src",
+        "http://mycroft.mozdev.org/nowrapper/submit-install.php/i/" + type +
"/" + name + "."+ ext,
+        name,
+        cat );
+    } else {      window.sidebar.addSearchEngine(
+        "http://mycroft.mozdev.org/plugins/"+name+".src",
+        "http://mycroft.mozdev.org/plugins/"+name+"."+ext,
+        name,
+        cat );
+    }  }
   else
   {
     errorMsg(name,ext,cat);
@@ -124,14 +129,14 @@
 //-->
 </script>
 			<ul>
-			    <li><a href="javascript:addEngine('a9','png','General')">A9 Search</a> -
Amazon's web and shopping search.</li>
-			    <li><a
href="javascript:addEngine('AltaVista','png','General')">AltaVista</a> - Another
popular way to search the web.</li>
-			    <li><a href="javascript:addEngine('jeeves','gif','General')">Ask
Jeeves</a> - Ask it questions and get answers.</li>
-			    <li><a href="javascript:addEngine('cddball','png','CDDB Music
Search')">CDDB</a> - Find album, artist, and song information.
-			    <li><a href="javascript:addEngine('leo','png','Language
dictionary')">LEO</a> - English to German translator.</li>
-			    <li><a href="javascript:addEngine('IMDB','png','Arts')">IMDB</a> - The
Internet Movie Database.</li>
-			    <li><a href="javascript:addEngine('webster','gif','Language
dictionary')">Merriam-Webster</a> - English dictionary search.</li>
-			    <li><a
href="javascript:addEngine('wikipedia_google','png','Reference')">Wikipedia</a>
- The incredible free encyclopedia.</li>
+			    <li><a href="javascript:addEngine('a9','png','General', '0')">A9
Search</a> - Amazon's web and shopping search.</li>
+			    <li><a href="javascript:addEngine('AltaVista','png','General',
'0')">AltaVista</a> - Another popular way to search the web.</li>
+			    <li><a href="javascript:addEngine('jeeves','gif','General', '0')">Ask
Jeeves</a> - Ask it questions and get answers.</li>
+			    <li><a href="javascript:addEngine('cddball','png','CDDB Music Search',
'0')">CDDB</a> - Find album, artist, and song information.
+			    <li><a href="javascript:addEngine('leo','png','Language dictionary',
'1875')">LEO</a> - English to German translator.</li>
+			    <li><a href="javascript:addEngine('IMDB','png','Arts', '0')">IMDB</a> -
The Internet Movie Database.</li>
+			    <li><a href="javascript:addEngine('webster','gif','Language dictionary',
'0')">Merriam-Webster</a> - English dictionary search.</li>
+			    <li><a href="javascript:addEngine('wikipedia_google','png','Reference',
'0')">Wikipedia</a> - The incredible free encyclopedia.</li>
 			    <li><a href="http://mycroft.mozdev.org/">Find lots of other search
engines...</a></li>
 			</ul>			
 	</div>

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 310092 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: mozilla.org → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.