The 'unless I have removed cookies set by this site' option is ignored on its initial setting

RESOLVED INVALID

Status

()

Firefox
Preferences
RESOLVED INVALID
13 years ago
11 years ago

People

(Reporter: paul_watkins9, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

After you initially check the'unless I have removed cookies set by this site',
any sites whose cookies you delete BEFORE exiting options are not added as
blocked to the exceptions list.

....For all subsequent visits to Options-->Privacy-->Cookies the setting causes
deleted sites/cookies to be blocked


Reproducible: Always

Steps to Reproduce:
1.Goto Options-->Privacy-->Cookies
2.check 'unless I have removed cookies set by this site'
3.Click 'View Cookies' and delete some
4.Goto to exception list



Actual Results:  
Cookies just deleted are not added as blocked on the exception list

Note: Leave 'unless I have removed cookies set by this site' checked, close
options and repeat 1,3&4 again, and now deleted cookies ARE set to block in the
exceptions list.

Expected Results:  
deleted cookies are blocked.

Comment 1

13 years ago
This is basically because instantApply defaults to false on Windows. This means
that changes you made in the prefs. window won't be applied till you click OK.
Turning on browser.preferences.instantApply will remedy this.

*** This bug has been marked as a duplicate of 237795 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 1.5 Branch
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> This is basically because instantApply defaults to false on Windows. 
> This means  that changes you made in the prefs. window won't be applied 
> till you click OK.

instantApply sits happily with events that are user 'neutral', ie actually when
history.dat is pruned after reducing the visited page count...

However, this case seems more like some other settings, where another option is
dependant on the tick box setting. So for UI consistancy the tick setting takes
effect immediately, and the behaviour of the dependant option changes before you
click OK.

For example:-

o In Content: 'Allowed Sites' for Block Popup Windows
o In Content: 'Allowed Sites' for Allow Web site to install software
o In Content: The 'advanced' button for Javascript in Content
o In Tabs:    Force links that open New Windows in
o In Downloads: Show download manager when downloads begin
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Version: 1.5 Branch → unspecified
(Reporter)

Comment 3

13 years ago
(In reply to comment #2

Ooops, I think I've failed to represent this situation clearly so far, pls read
on....

...After you first tick 'unless I have removed cookies set by this site' any
cookie(s) you delete won't show up in the exceptions list, because as as you
explained, instantApply is false - If I'm unhappy I can change the pref...

  However if you exit/re-enter options they are still not there, ie your initial
changes have been lost.  

...It's this Dataloss I've been 'trying' to report .... I didn't notice the
exceptions list wasn't updated initially until you explained .... 
(Reporter)

Comment 4

13 years ago
As there several related bugs, a suggestion (posted this in #309303 by mistake)

Move the 'unless I have removed cookies set by this site' function back to the
View Cookies panel, as per 1.0x, but this time as an extra button, not a check
box. This would give you 3 buttons, besides close:-

1. Remove Cookie(s)
2. Remove Cookie(s) and Block Site
3. Remove all Cookies

Button 2 has the function currently assigned to 'unless I have remove cookies
set by the site' 

This also highlights that 'Remove all Cookies' won't block them. You would need
to select them individually and click 2.

If the 'View Cookies' button is extended to 'View Cookies & Block Sites', 
this would maintain visibility on the panel of how to block site easily. 
Missing in 1.0x, but the 'unless I have removed cookies set by the site' now
provides.



Comment 5

13 years ago
If you had read bug 237795 then you would have figured out that it's exactly
what you're talking about -- hence me marking this bug as a dupe of it. Also,
this bug is not about redesigning the cookie manager UI. If you think changed
need to be made then file a bug for it; that is, assuming there isn't one
already filed.

*** This bug has been marked as a duplicate of 237795 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE

Comment 6

13 years ago
Strictly speaking Bug 237795 no longer occurs (Fx 1.5 on Win XP), but this bug does occur, wouldn't it be more correct (and make searching easier) to close that bug and keep this bug open?

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
OS: Windows 2000 → Windows XP
Resolution: DUPLICATE → ---
Summary: The 'unless I have removed cookies set by this site' options is ignored on it's initial setting → The 'unless I have removed cookies set by this site' option is ignored on its initial setting
Version: unspecified → Trunk

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

13 years ago
Created attachment 206161 [details] [diff] [review]
patch

This makes sense to me. In most cases, someone is going to open up this dialog and see that pref. and say, "Hey, that's cool. Let me enable this and go delete some cookies that I don't want to be set again." So having it apply immediately is crucial.
Assignee: nobody → ispiked
Status: NEW → ASSIGNED
Attachment #206161 - Flags: review?

Updated

13 years ago
Attachment #206161 - Flags: review? → review?(bugs)
(In reply to comment #7)
> Created an attachment (id=206161) [edit]
> patch

That would seem just wrong to me. I open the options, tick that box then click cancel because I changed my mind. With this patch in place it will set that setting when I didn't expect it to.
The solution I would suggest would be to turn the cookies dialog into a child prefwindow and have a preference element on it for network.cookie.blockFutureCookies that it queries rather than asking the actual preferences. Then since bug 309041 is in place that preference element should automatically take on the current value of the matching preferences element from the main options.
(In reply to Dave Townsend (Mossop), comment #9)
> The solution I would suggest would be to turn the cookies dialog into a child
> prefwindow and have a preference element on it for
> network.cookie.blockFutureCookies that it queries rather than asking the actual
> preferences. Then since bug 309041 is in place that preference element should
> automatically take on the current value of the matching preferences element
> from the main options.
> 

This really needs some UI-review, the cookies window was designed not to be a modal window (So you can leave it open when the main preferences window is closed).

Updated

13 years ago
Assignee: ispiked → nobody
Status: ASSIGNED → NEW
Attachment #206161 - Flags: ui-review?(beltzner)
I think that bug 340677 is going to make this patch invalid. As I understand it, this checkbox was created to replace a "Remove and Block" button in the cookie manager. That button should really be restored, as that's a much more sensible place to put this sort of function.

Comment 13

11 years ago
Beltzner is indeed correct. Bug 340677 removed this UI. ->INVALID
Status: NEW → RESOLVED
Last Resolved: 13 years ago11 years ago
Resolution: --- → INVALID

Updated

11 years ago
Attachment #206161 - Flags: ui-review?(beltzner)
You need to log in before you can comment on or make changes to this bug.