Last Comment Bug 310618 - Printing support for svg/cairo/win32
: Printing support for svg/cairo/win32
Status: RESOLVED FIXED
: fixed1.8
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: tor
: Hixie (not reading bugmail)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-30 14:00 PDT by tor
Modified: 2005-10-03 14:12 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
win32 cairo printing (5.56 KB, patch)
2005-09-30 14:01 PDT, tor
roc: review+
roc: superreview+
asa: approval1.8b5+
Details | Diff | Splinter Review

Description tor 2005-09-30 14:00:54 PDT
The cairo win32 backend doesn't seem to like being handed a printing DC, so one
way of getting something to print is to use the image generation code that was
added for linux.  Since the win32 print code blends RGBA images with black, we
modify the code a bit to preblend with white and hand off just RGB to DrawImage.
Comment 1 tor 2005-09-30 14:01:33 PDT
Created attachment 198045 [details] [diff] [review]
win32 cairo printing
Comment 2 Robert O'Callahan (:roc) (email my personal email if necessary) 2005-09-30 14:48:39 PDT
Comment on attachment 198045 [details] [diff] [review]
win32 cairo printing

too bad we can't do any kind of transparency on Win32 (right?) but this'll do
Comment 3 tor 2005-10-01 21:06:16 PDT
Checked in on trunk.
Comment 4 tor 2005-10-01 21:07:44 PDT
Comment on attachment 198045 [details] [diff] [review]
win32 cairo printing

This patch is needed to provide printing support for SVG when using the cairo
backend on win32.  It is adapting code already used to print on unix, so the
additional risk is small.
Comment 5 Asa Dotzler [:asa] 2005-10-03 10:50:53 PDT
Comment on attachment 198045 [details] [diff] [review]
win32 cairo printing

last day for non-critical changes.
Comment 6 tor 2005-10-03 14:12:53 PDT
Checked in on branch.

Note You need to log in before you can comment on or make changes to this bug.