Closed Bug 31068 Opened 20 years ago Closed 20 years ago

crash loading preview.cdf channel

Categories

(Core :: Networking, defect, P3, critical)

x86
Windows NT
defect

Tracking

()

VERIFIED DUPLICATE of bug 29858

People

(Reporter: buster, Assigned: mscott)

References

()

Details

(Keywords: crash)

I was surfing, so I'm not sure what URL I had loaded or what URL I was about to 
load.  But I got a crash blowing my stack, with thousands of these calling down 
recursively:

nsDocumentOpenInfo::OnStartRequest(nsDocumentOpenInfo * const 0x0d5c4b40, 
nsIChannel * 0x0c92b7a0, nsISupports * 0x00000000) line 254 + 34 bytes


I think I clicked on a bookmark in my sidebar while another page was still 
loading, if that makes any difference.  Will try to narrow down how this 
happened.
sorry, should have said:
debug build on WinNT, bits from 10:30 am this morning.
eureka!
the problem is simply loading this url:
http://channel.web.aol.com/preview.cdf

This is from the "Imported IE Favorites" folder in my bookmarks.  It doesn't 
matter how you load it, from bookmarks, typing it into url bar, etc.
Summary: crash switching documents → crash loading preview.cdf channel
My build isn't done yet. I wonder what kind of content type is associated with cdf?
When I try this link in navigator I get an unknown file type */* alert.  When I 
paste the URL in the addressbar of ie and hit enter it prompts me to add a "AOL 
Preview Channel" to the ie sidebar.  if I accept it then loads 
http://channel.web.aol.com/channel2/index.html in the content area.
Severity: normal → critical
Keywords: crash
No crash using the 2000-04-09-08-M15 nightly binary on WinNT; loading 
preview.cdf  behaves the same as NN 4.x, with an Unknown File Type Dialog for 
type */*; saving or cancelling work fine.

IIRC, .cdf is for the MS-proprietary Channel Definition Format.

This is not the only bug recently having to do with crashes with unknown
content types: see bug 29360, "Crash after Unknown Type dialog comes up.",
FIXED just post-M14.
This sure does look like a DUP of bug 29858, "File type of */* crashes 
Mozilla.", FIXED -- identical URL and problem.


*** This bug has been marked as a duplicate of 29858 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Component: Browser-General → Networking
QA Contact: asadotzler → tever
Resolution: --- → DUPLICATE
dupe of bug 29858
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.