Java applet will not load because firefox susbstitutes the "~" symbol for "%7E" symbol.

VERIFIED INVALID

Status

()

--
minor
VERIFIED INVALID
13 years ago
13 years ago

People

(Reporter: alex.gould, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

The java applet WILL load if I manually SWITCH the "%7E" symbol back to the "~"
symbol.  This is a manual fix but it does not work automatically.

Reproducible: Always

Steps to Reproduce:
Example website:  try going to http://www.stanford.edu/~alxgould/econ111

1. This first loading will work fine and you can see the blue applets on the left.
2. Then click on ANY of the blue applets.  When the next page loads, it will
make that sign substitution and those blue applets won't load.  
3. If you correct the sign susbstitution in the URL and re-load, the blue
applets will load.

Actual Results:  
Clicking on the blue applets should not lead to a substitution of the symbols.

Expected Results:  
Maintain the "~" symbol from page to page.
This seems to be caused by a bug in Java 1.3.1 (possibly just in Apple's
implementation of it) -- you also see it if you force Safari to use Java 1.3.1.

It's fixed in Apple's later Java implementations (1.4.X and higher).

You can make Firefox (and any other Mozilla-family browser) use later Java
versions of OS X by installing the Java Embedding Plugin
(http://javaplugin.sourceforge.net/).

The Java Embedding Plugin is also bundled with more recent versions of
Mozilla-family browsers (http://www.mozillazine.org/talkback.html?article=7230).

This is a bug with java. As mentioned the java embedded plugin thats included
with recent devlopment builds fo firefox should fix it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

13 years ago
Thanks for the suggestions -- I downloaded the JAVA update and got it to work.

Take care,

Alex
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.