Firefox reports wrong version to update to

RESOLVED FIXED

Status

()

RESOLVED FIXED
13 years ago
10 years ago

People

(Reporter: Peter6, Assigned: chase)

Tracking

1.8.0 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
When you do an incremental update from 

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20051001
Firefox/1.4 Nightly

to

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20051001
Firefox/1.4.1

The Update Dialog should report the update as 1.4.1 not 1.4

sceenshot next
(Reporter)

Comment 1

13 years ago
Created attachment 198143 [details]
Update dialog

wrong version number in 2 update dialog windows
(Reporter)

Comment 2

13 years ago
this in NOT a dupe of Bug 305261 !
(Reporter)

Comment 3

13 years ago
form 

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20050930
Firefox/1.4 Nightly

to

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20051001
Firefox/1.4.1 Nightly
(Assignee)

Comment 4

13 years ago
This is a known "bug" with the software update infrastructure.  I didn't have
time when I was hooking the build systems into the server to read all of this
data from a variety of sources in what I would consider the best way, so I
embedded the information locally.  Unfortunately that means that whenever the
version is bumped I need to update (3 platforms) * (2 branches) = 6 build systems.

The short term fix will be implemented today.  I'll update those build systems.

The "best way" fix will be implemented soon and I'll use this bug to track some
of the patches.
Assignee: nobody → chase
(Assignee)

Comment 5

13 years ago
(In reply to comment #4)
> version is bumped I need to update (3 platforms) * (2 branches) = 6 build systems.

s/branches/products/
Status: NEW → ASSIGNED
(Assignee)

Comment 6

13 years ago
(In reply to comment #4)
> The short term fix will be implemented today.  I'll update those build systems.

Build systems updated for Firefox and Thunderbird on the Mozilla 1.8 branch.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.