All users were logged out of Bugzilla on October 13th, 2018

move / copy xul template menus "slower" than they used to be

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: sspitzer, Assigned: mscott)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

move / copy xul template menus "slower" than they used to be

I'm using version 1.6a1 (20051001), but I've probably seen this since the 9-29
builds.

my move / copy xul template menus take longer to show up than they used to.

maybe this will help:

1)  I select a message in my inbox, and go to file it using the message | move menu
2)  that menu is slow to pop up
3)  do it again, with another message in my inbox, and it's ok
4)  switch to another folder on another server, and it is slow again.

specifically, it isn't the list of server (in the message | move menu) that are
slow to show up, it is the child folders of those servers.
for what it is worth, I've noticed that the "Save Message" dialog is also slower
than it used to be.

to reproduce that:

1)  new message
2)  type in the body
3)  attempt close the compose window
4)  the "save message" dialog comes up

notice how slow it takes for the window to come up, and then "paint".

I'm using version 1.6a1 (20051002) on windows xp (on fast machine)
the reason I brought that up is that in both cases (the save message window and
the file menus) is the "window" comes up slow, outline first, and then it
paints.  so both "windows" have the same slow "feeling".
(Assignee)

Comment 3

13 years ago
both of these things look good on the branch. So the problem isn't there which
is good.
thanks for the info, scott.

I'm noticing this slowness all over, the spell check dialog, send progress
dialog, etc.

I wonder if there is trunk performance regression that is hurting tbird?

I don't see it on firefox (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.8b5) Gecko/20050930 Firefox/1.4)

is that the same "trunk", or is my firefox from the branch?
(Assignee)

Comment 5

13 years ago
1.4 means branch.
QA Contact: front-end

Updated

11 years ago
Depends on: 413781
(In reply to comment #0)
> 1)  I select a message in my inbox, and go to file it using the message | move menu
> 2)  that menu is slow to pop up
> 3)  do it again, with another message in my inbox, and it's ok
> 4)  switch to another folder on another server, and it is slow again.

(In reply to comment #3)
> both of these things look good on the branch. So the problem isn't there which
> is good.

WFM on 2.0.0.12 as well.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.