adjascent sibling properties only applied once

RESOLVED INVALID

Status

()

RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: pygy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

There are three div tags in the #main div. In the linked page. Each one contains
an h3 followed by a paragraph.

The following rule is only applied to the first paragraph, for no apparent reason.
#main h3 + p{margin-top: -60px;}

This doesn't happen in Opera nor IE6 + Dean Edwards IE7 0.9 (although there are
other nasty rendering bugs in IE)

Reproducible: Always

Steps to Reproduce:
Load the linked page, the bug is exhibited immediately.

Actual Results:  
The paragraph of the first div is the only one to get the -60px margin

Expected Results:  
All paragrapphs should get the negative margin, since they all follow an h3 tag.
(Reporter)

Comment 2

14 years ago
Yeah, sorry, my mistake. I realised menanwhile that the html wasn't properly formed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.