Last Comment Bug 310736 - Scrollbars not being recalculated on resize
: Scrollbars not being recalculated on resize
Status: RESOLVED FIXED
: fixed1.8, testcase
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: x86 Windows 2000
: -- normal (vote)
: ---
Assigned To: Robert O'Callahan (:roc) (email my personal email if necessary)
:
:
Mentors:
Depends on:
Blocks: 307158
  Show dependency treegraph
 
Reported: 2005-10-01 15:37 PDT by G Evans
Modified: 2005-10-04 17:49 PDT (History)
6 users (show)
mscott: blocking1.8b5+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (2.21 KB, text/html)
2005-10-01 15:38 PDT, G Evans
no flags Details
testcase2 (767 bytes, text/html)
2005-10-01 22:39 PDT, Martijn Wargers [:mwargers] (not working for Mozilla)
no flags Details

Description G Evans 2005-10-01 15:37:30 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20051001 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20051001 Firefox/1.6a1

Appeared after resolution of Bug 307158 and is likely caused by it's fix.

When the window is resized to a smaller size the horizontal scrollbar reapears
as in 307158 but disappears and functions correctly when refreshed. When the
window is maximised the scrollbars disapear but their space remains. After a
refresh the view is corrected.

It apears that the viewport size is not being refreshed correctly on resize but
is on the refresh.

I will add a testcase.


Reproducible: Always

Steps to Reproduce:
1.resize untill vertical scrollbar shows up
2.maximise
3.refresh
4.minimise
5.refresh

Actual Results:  
Scrollbars and spaces appear and disappear

Expected Results:  
Screen should recalculate on resize as it does on refresh.
Comment 1 G Evans 2005-10-01 15:38:54 PDT
Created attachment 198170 [details]
testcase

Open testcase and resize/refresh
Comment 2 Martijn Wargers [:mwargers] (not working for Mozilla) 2005-10-01 22:39:03 PDT
Created attachment 198191 [details]
testcase2

I noticed this bug too.
Another peculiarity of this testcase is that the push buttons of the scrollbar
are already active when there is nowhere to scroll.
Comment 3 Scott MacGregor 2005-10-03 15:35:38 PDT
re-assigning to roc per the reporter's comment that this was caused by 307158. 
cc'ing dbaron

Do we think this is worse than what was getting fixed in 307158? Backing out
307158 may be our only re-course this close to the deadline.
Comment 4 G Evans 2005-10-03 16:01:13 PDT
307158 could be a web site breaker and is a big step back on web
standardisation. Perhaps ROC can come up with a better fix?
Comment 5 Asa Dotzler [:asa] 2005-10-03 18:04:18 PDT
dbaron, can you help us out on this? roc's gone and we're trying to ship
something in the next day or two. We'd need something really quick and really
safe :-)
Comment 6 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2005-10-03 18:11:39 PDT
It seems like the basic problem is that nsHTMLScrollFrame::ReflowScrolledFrame
doesn't change the result of GetActualScrollbarSizes for the duration of the
call based on its aAssumeVScroll parameter, so the actual scrollbar sizes aren't
the ones that are going to be used if the current reflow returns usable results.
 I don't think making it do so is a good way to fix this, though.
Comment 7 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2005-10-03 18:18:13 PDT
My inclination is to back out bug 307158 because of what I said in the previous
comment.
Comment 8 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2005-10-03 19:16:33 PDT
Fixed by backout, trunk and 1.8 branch.
Comment 9 Scott MacGregor 2005-10-04 17:49:38 PDT
cleaning up a nomination flag for something we fixed.

Note You need to log in before you can comment on or make changes to this bug.