index.cgi invalid HTML when logged out

RESOLVED FIXED in Bugzilla 3.0

Status

()

defect
--
minor
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: bugreport, Assigned: spam)

Tracking

({regression})

Bug Flags:
approval +

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

14 years ago
The login form is in the middle of a list but outside an LI


Error at line 85, character 133:  element "FORM" not allowed here; assuming
        missing "LI" start-tag
(Reporter)

Updated

14 years ago
Keywords: regression
(Reporter)

Updated

14 years ago
Summary: index.cgi does not validate when logged out → index.cgi invalid html when logged out

Comment 1

14 years ago
I see no interest in having the list of URLs using <ul><li>. We could get the
same UI using <br> between each line. This would also fix this error.

Updated

14 years ago
Summary: index.cgi invalid html when logged out → index.cgi invalid HTML when logged out
Having a list, it's generally a good idea to use a ul, since that's what a ul is
for. We could just split up the ul.

Comment 3

14 years ago
What I meant is that we don't need a list here.
Posted patch patch for tip (obsolete) — Splinter Review
took mkanat's approach :-P
Attachment #233213 - Flags: review?

Comment 5

13 years ago
Comment on attachment 233213 [details] [diff] [review]
patch for tip

Note that my HTML Validator complains that the ID and name are different in:

<form id="show-bug" name="f" action="buglist.cgi" method="get"

We can fix that in a separate patch though.

r=LpSolit
Attachment #233213 - Flags: review? → review+

Updated

13 years ago
Assignee: myk → bmo
Severity: normal → minor
Flags: approval?
Target Milestone: --- → Bugzilla 3.0
use same id and name
Attachment #233213 - Attachment is obsolete: true
Attachment #233227 - Flags: review?

Updated

13 years ago
Attachment #233227 - Flags: review? → review+
Flags: approval? → approval+

Comment 7

13 years ago
Checking in template/en/default/index.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/index.html.tmpl,v  <--  index.html.tmpl
new revision: 1.30; previous revision: 1.29
done
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.