Advanced search page fails w3 validation

RESOLVED FIXED in Bugzilla 3.0

Status

()

defect
--
minor
RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: bugreport, Assigned: spam)

Tracking

2.21
Bugzilla 3.0
Bug Flags:
approval +

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

14 years ago
Below are the results of attempting to parse this document with an SGML parser.

   1. Error Line 98 column 92: end tag for element "A" which is not open.

...format=advanced'>Give me some help</a> (reloads page.)</p>");

      The Validator found an end tag for the above element, but that element is
not currently open. This is often caused by a leftover end tag from an element
that was removed during editing, or by an implicitly closed element (if you have
an error related to an element being used where it is not allowed, this is
almost certainly the case). In the latter case this error will disappear as soon
as you fix the original problem.

      If this error occured in a script section of your document, you should
probably read this FAQ entry.

      ✉
   2. Error Line 98 column 112: end tag for element "P" which is not open.

...e me some help</a> (reloads page.)</p>");

      The Validator found an end tag for the above element, but that element is
not currently open. This is often caused by a leftover end tag from an element
that was removed during editing, or by an implicitly closed element (if you have
an error related to an element being used where it is not allowed, this is
almost certainly the case). In the latter case this error will disappear as soon
as you fix the original problem.

      If this error occured in a script section of your document, you should
probably read this FAQ entry.
Posted patch patch for tip (obsolete) — Splinter Review
divide between < and /
Attachment #233211 - Flags: review?

Comment 2

13 years ago
Comment on attachment 233211 [details] [diff] [review]
patch for tip

>-      document.write("<p><a href='query.cgi?help=1&amp;format=advanced'>Give me some help</a> (reloads page.)</p>");
>+      document.write('<p><a href="query.cgi?help=1&amp;format=advanced">Give me some help<' + "/a> (reloads page.)<" + "/p>");


No! They must be correctly escaped: in document.write(), </foo> must be written <\/foo>
Attachment #233211 - Flags: review? → review-
Attachment #233211 - Attachment is obsolete: true

Comment 4

13 years ago
Comment on attachment 233369 [details] [diff] [review]
patch for tip v2

r=LpSolit
Attachment #233369 - Flags: review? → review+

Updated

13 years ago
Assignee: myk → bmo
Flags: approval?
Target Milestone: --- → Bugzilla 3.0
Flags: approval? → approval+

Comment 5

13 years ago
Checking in template/en/default/search/search-advanced.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/search/search-advanced.html.tmpl,v  <--  search-advanced.html.tmpl
new revision: 1.26; previous revision: 1.25
done
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.