The default bug view has changed. See this FAQ.

Unable to select most menu items using keyboard when error page is shown.

VERIFIED FIXED

Status

()

Core
Document Navigation
--
major
VERIFIED FIXED
12 years ago
11 years ago

People

(Reporter: Steve H, Assigned: Jesse Ruderman)

Tracking

({access, fixed1.8, regression})

Trunk
access, fixed1.8, regression
Points:
---
Bug Flags:
blocking1.8b5 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

My home page is only available when attached to the corporate LAN. When I start
Firefox attached to my home LAN I get "The Connection has time out" page with
the "Try again" button.

Trying to select any bookmark via the keyboard (ALT-B, down arrow several times,
then pressing enter) with the timeout page present, appears to try the timed out
page again.  However, selecting any bookmark via the mouse works OK.

Reproducible: Always

Steps to Reproduce:
1. set home page to a url that will timeout.
2. completely close firefix.
3. open firefix and eait for connection has timed out page to appear.
4. press alt-b, then page down to a bookmark and hit enter
5. the connection has timed out page will remain.

Actual Results:  
the "connection has timed out" page remained on the screen.

Expected Results:  
firfox should have selected the bookmark that was highlighted when the enter key
was pressed.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20051002
Firefox/1.4.1 ID:2005100204

Confirmed

easy repro:
1. type a non existing url in the locationbar , hit enter and waitfor the
"server not found" message.
2. hit alt-b ,select a bookmark and press enter
3. the page reloads the old url

Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Unable to select bookmarks via keyboard after "The connection has timed out" page has appeared. Bookmark selection by mouse OK. → Unable to select bookmarks via keyboard after (xul) errorpage has appeared. Bookmark selection by mouse OK.
works in 20050821 0714 pdt build

fails in 20050821 1057 pdt build

http://tinderbox.mozilla.org/bonsai/cvsquery.cgi?treeid=default&module=AviarySuiteBranchTinderbox&branch=MOZILLA_1_8_BRANCH&branchtype=match&filetype=match&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2005-08-21+06%3A30%3A00&maxdate=2005-08-21+10%3A20%3A00&cvsroot=%2Fcvsroot

only Bug 305041 (Timeless)
Severity: minor → major
Keywords: access, regression
Flags: blocking1.8b5?
Summary: Unable to select bookmarks via keyboard after (xul) errorpage has appeared. Bookmark selection by mouse OK. → Unable to load bookmark via keyboard after (xul) errorpage has appeared. Bookmark selection by mouse is OK.
It's also happen with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1)
Gecko/20051001 Firefox/1.6a1
OS: Windows 2000 → All
Version: unspecified → Trunk
This has nothing to do with bug 305041 as can be checked by local backout.  That
said, the regression range in comment 2 just generally looks wrong to me -- the
one I see is 2005-08-20-06 to 2005-08-21-07.  And the checkin for bug 301471 in
that range is what causes this bug (tested via backout).  I have no idea why
we're triggering that button when we hit enter on a menu item; aaron, bryner,
mats, that sounds like your sort of thing.
Assignee: nobody → adamlock
Blocks: 301471
Component: Bookmarks → Embedding: Docshell
Product: Firefox → Core
QA Contact: bookmarks → adamlock
Hardware: PC → All
I suggest bug 301471 be backed out if we can't find a fix for this in a timely
manner (like today)...
(In reply to comment #5)
> I suggest bug 301471 be backed out if we can't find a fix for this in a timely
> manner (like today)...

backing out bug 301471 indeed fixes it (just tried it out on the latest build)

Comment 7

12 years ago
Jesse, this looks like you. Time is short and we need either a fix or a backout
patch ASAP.
Assignee: adamlock → jruderman
(Assignee)

Comment 8

12 years ago
I doubt that a fix for an underlying focus problem would be safe enough for the
branch at this point.  I won't be able to try to create a workaround (in
netError.xhtml) until tomorrow.  bz, feel free to back out the patch for 
bug 301471 if you feel this regression is worse than not focusing the button
automatically.

Does this affect all menu items? All menu items without accesskeys (e.g. also
the Go menu)?  Only bookmarks?
(In reply to comment #8)
> Does this affect all menu items? All menu items without accesskeys (e.g. also
> the Go menu)?  Only bookmarks?

Yes, at least the most menu items are affected. A lot of them don't work when
the try again button has focus. The menu items Go|Home and Go|Back also don't
work and they have accesskeys.
Summary: Unable to load bookmark via keyboard after (xul) errorpage has appeared. Bookmark selection by mouse is OK. → Unable to select most of the menu items with a keyboard when (xul) error page is shown.
(Assignee)

Updated

12 years ago
Summary: Unable to select most of the menu items with a keyboard when (xul) error page is shown. → Unable to select most menu items using keyboard when error page is shown.
Jesse, I'm probably not going to be in a position to check anything in before
the freeze, so if you could back out bug 301471 or find someone on IRC who can
do it, that would be appreciated.  The way I see it, for mouse users it doesn't
matter which way we go, and for keyboard users it's having to tab one extra time
to reload on the one hand and pretty unusable menus on the other.  Given that
choice, I think hitting tab an extra time is preferable...

Comment 11

12 years ago
We need this backout today. Who can help?
Flags: blocking1.8b5? → blocking1.8b5+
(Assignee)

Comment 12

12 years ago
I'll back it out.
(Assignee)

Comment 13

12 years ago
Created attachment 198335 [details] [diff] [review]
backout patch (trunk)

Assuming I don't need reviews for a simple backout.  I will check this in
(trunk and branch) when the trees are green.
Shouldn't this only be backed out on the branch, and left on the trunk so that
the actual bug can be fixed?
I'd file a separate bug on the focus issue, blocking (reopened) bug 301471
(Assignee)

Comment 16

12 years ago
Fix for bug 301471 backed out, trunk and branch.  I will reopen bug 301471 and
file a bug on the underlying focus bug once I figure out what that bug is.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
The bug there is that if the button has focus hitting enter triggers it, even if
you hit enter on a menu....
Works fine now. Thanks.
Status: RESOLVED → VERIFIED

Updated

12 years ago
Keywords: fixed1.8
You need to log in before you can comment on or make changes to this bug.