many localizations browser.throbber.url still points to old URL (upgrade message)

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: joseph.wright, Assigned: Pike)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
Loading the Firefox start page using the en-GB version of FF 1.0.7 (e.g. by
clicking the throbber) is currently bringing up the "An update is available"
page, rather than the normal start page.  However, 1.0.7 is the current stable
release.

Steps to reproduce:
1. In 1.0.7 en-GB, click the throbber
2. Note wrong page is loaded

This may well be more general - is it true for everthing which isn't en-US?  May
well apply to other platforms too - I don't have the setup to test.
(Reporter)

Comment 1

13 years ago
Update: changing general.useragent.locale in about:config to de, es, etc. gives
the expected results.   Is this limited to sub-sets of en (except en-US)?
(Reporter)

Comment 2

13 years ago
What is particularly annoying is the the fact I'm sending en-GB as first-choice
language is picked up, so the download I'm offered is the english (British)
version.  I've already installed it, of course.  You could end up in an endless
loop here!  
The URL you gave above is the upgrade page that you're redirected to, right? 
What's the URL of the start page in your browser preferences?  (Is that the page
that's doing the redirecting, or is it the page you get only the first time you
start the browser that's doing the redirecting?)
Or are you keeping the homepage configuration from a pre-1.0 Firefox release?
(Reporter)

Comment 5

13 years ago
(In reply to comment #3)
> The URL you gave above is the upgrade page that you're redirected to, right? 
> What's the URL of the start page in your browser preferences?  (Is that the page
> that's doing the redirecting, or is it the page you get only the first time you
> start the browser that's doing the redirecting?)

Okay, brand new install, new profile, etc.  I press the throbber, I get:

http://www.mozilla.org/products/firefox/start/

In about:config, I have browser.throbber.url as exactly the same string, so I
guess that it what the throbber is supposed to load. 

BTW, the default home page is:

http://www.google.co.uk/firefox?client=firefox-a&rls=org.mozilla:en-GB:official

I hope all of this makes sense!

(Reporter)

Comment 6

13 years ago
Further testing with a brand new install gives the same result for any version
of en -> must be the URL I'm being sent to.  INVALID - sorry for the bugspam, I
must have had something lurking around.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
There is a real bug here, though, which is that browser.throbber.url's default
varies by localization, and the values for a large number of the localizations
haven't been updated since the en-US location changed well before Firefox 1.0. 
Things are better on the trunk than the aviary branch, but a whole bunch of them
still point to the URL that's a guaranteed upgrade message (the old start page,
http://www.mozilla.org/products/firefox/start/ ).
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Assignee: mozilla.webmaster → l10n
Status: UNCONFIRMED → NEW
Component: webmaster@mozilla.org → General
Ever confirmed: true
Product: mozilla.org → Firefox
Summary: Firefox start page / throbber - "Update Firefox" page shown when loading using en-GB version of FF 1.0.7 → many localizations browser.throbber.url still points to old URL (upgrade message)
Version: other → Trunk
On the trunk this is a problem with da, nl, pa-IN, and sq.  On the aviary branch
it's a problem with a lot more.
Neatly resolved by bug 329601 removing the whole "click the throbber" thing.
Status: NEW → RESOLVED
Last Resolved: 13 years ago12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.