If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Pressing enter in "<URL> could not be found dialog" reloads page

VERIFIED WORKSFORME

Status

()

Core
Event Handling
P3
normal
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: Eli Goldberg, Assigned: joki (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-], URL)

(Reporter)

Description

18 years ago
* TITLE/SUMMARY
Pressing enter in "<URL> could not be found dialog" reloads page

* STEPS TO REPRODUCE
0) Launch Apprunner
1) Type in a URL to a nonexistent site, e.g. http://
www.mozillaisgoingtoshipsomedayreallysoonihope.com
2) A dialog appears to note that URL isn't correct. Browser window fades into 
background. Press enter to dismiss it.

* RESULT
 - What happened

The dialog disappears, and then re-appears --- the event both dismisses the 
dialog, and reloads the URL.

Simply clicking on the "OK" button, however, results in proper dialog dismissal.

 - What was expected 

Key events shouldn't go to background windows.

* REGRESSION

 - Occurs On
        Mac OS, Linux & Win32 Apprunner (20000 3.08.00 PM optimized build)		


* CONFIGURATIONS TESTED

- [Mac] Beige Power Mac G3 (266 MHz PowerPC 750), 96 MB RAM (VM on; 1 MB of VM 
used), 1024x768 (Thousands of Colors), Mac OS 8.6

- [Win32] Vectra VL (233 MHz P2), 96 MB RAM, 800x600 (True Color), NT 4.0 SP5.

- [Linux] Vectra VL (266 MHz P2), 96 MB RAM. Red Hat Linux 6.0 (GNOME).
(Reporter)

Comment 1

18 years ago
Nominating for beta2.
Keywords: beta2
(Assignee)

Comment 2

18 years ago
Hmm.  Not sure whose this is.  Might be saari, might be me.  Chris?  You have 
any comments?

Comment 3

18 years ago
Eh, don't know who's this should be. 

Updated

18 years ago
Keywords: nsbeta2

Comment 4

18 years ago
Putting on [nsbeta2-] radar. 
Whiteboard: [nsbeta2-]
(Assignee)

Comment 5

18 years ago
Coolnees.  This works for me now.  I'm going to credit saari, that seems likely.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 6

18 years ago
verified fixt.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.