Navigator (and other windows) don't persist position between launches

RESOLVED INVALID

Status

()

defect
P3
normal
RESOLVED INVALID
20 years ago
18 years ago

People

(Reporter: mikepinkerton, Assigned: danm.moz)

Tracking

({regression})

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

- launch apprunner
- move the navigator window to a new location
- quit and relaunch

expected results:
- nav window is where you left it

actual results:
- nav window is where it was at last launch

This oddly seems to work just fine when closing/reopening w/in the same launch.
Keywords: regression
Assignee

Updated

20 years ago
Target Milestone: M17

Comment 1

19 years ago
Mass moving M17 bugs to M18
Target Milestone: M17 → M18

Comment 2

19 years ago
A note for MailNews to check scenarios in bug# 24363.

Comment 3

19 years ago
*** Bug 38005 has been marked as a duplicate of this bug. ***

Comment 4

19 years ago
mass-moving all bugs to m21 that are not dofood+, or nsbeta2+
Target Milestone: M18 → M21

Updated

19 years ago
OS: Mac System 9.0 → Linux
Hardware: Macintosh → PC
Summary: Navigator doesn't persist its position between launches → Navigator (and other windows) don't persist position between launches
Assignee

Updated

19 years ago
Target Milestone: M21 → Future

Comment 5

19 years ago
This is really, really nasty in M18. Mozilla M18 2000101014 release, Mac OS 9.0.4 -

1) Resize window to max
2) Quit Mozilla
3) Restart Mozilla (and/or open a new window)

The window has remembered the size of the last window open when Mozilla was quit
but, unfortunately, it does not remember or is not smart enough to figure out
the correct position for the window. Windows open up with the (0,0) coordinate
(top-left corner) toward the center of the screen. The bottom and right side of
the browser window end up off-screen, making M18 very difficult to use (unless
you like to reposition the browser window every time you restart Mozilla or
create a new window or you never resize you browser window).

Happens on Mac OS, not sure about other platforms (I'm assuming All/All). I'm
not changing anything, though (leave that up to whoever verifies (or not) this).

Comment 6

19 years ago
This is under the final M18 milestone (avail. 10/12/00), BTW.

Comment 7

19 years ago
Anybody? I'm still seeing this under the most current M18 builds under Mac OS. 
Now that the browser window's size persists, this bug really hinders my ability 
to use Mozilla.
Assignee

Comment 8

19 years ago
  I didn't realize this was a problem on the Mac: the bug's OS field says just 
Linux. Linux will have this problem -- I was about to close this bug "invalid" 
because the Linux build explicitly skips the window positioning code, choosing to 
allow the window manager to place the windows as it sees fit. The Mac's a 
different issue.
  Hang on Smiles -- are you describing a different problem? After rereading your 
post a couple of messages up, are you sizing the window large by zooming or 
dragging? All size and position persistence is disabled while zoomed, which is 
what I see on my machine. If not zoomed, the window's size shouldn't affect 
persistence; it should be equally effective at all sizes.
  Hang on again -- are you on a multiple monitor machine? Is your main (menubar) 
monitor on the right and/or below the other one? I remember a bug like that from 
a long time ago. If so, please try to track down what causes the problem exactly. 
I have a simple monitor setup (one) and don't see anything wrong.
  If that's what you're seeing, it wants to be in a different bug. Either a new 
one or if you can find and reopen the ancient one that I'm pretty sure exists 
somewhere, that'd be fine, too. *This* bug, as originally filed, is going to die 
an invalid death real soon now.

Comment 9

19 years ago
I have a single monitor setup. The bug in question happens when clicking the 

resize button in the upper-right corner of the window. Clicking on this button 

sets the browser window to the maximum size. In older releases (pre-M18), the 

size of the browser window did not persist between sessions. If you "maximized" a 

window, quit and then relaunched Mozilla, the browser window would be the default 

size. Starting with M18, if you quit and relaunch Mozilla, the size of the 

browser window is remembered.



The problem here is that the window size is remembered but the position is not. 

If you maximize the window, quit and restart Mozilla, the new window that opens 

will be in the default position but will be the size you set it. You end up with 

a browser window that is the maximum size but is in the default position (where 

the defualt browser window size would be centered on screen) with the bottom and 

right edges of the window appearing off-screen.



Should a new bug get filed for this? There are a lot of "window-size and/or 

window-position not remembered" bugs already (I just picked one). And somebody 

please tell me you can reproduce this. I have experienced this with numerous 

post-M18 builds, deleting all of the data files before running a new build. This 

bug makes using Mozilla next-to-impossible because I have to move the window 

everytime I launch Mozilla/open a new window (or not resize the browser window at 

all).

Assignee

Comment 10

19 years ago
  Hmm. I'm afraid I don't see any of this on my Mac build (or Windows. Linux, see 
above). It's doing what we ask for me, which is remembering nothing of size or 
position while zoomed/maximized. It's not even remembering that it was zoomed 
(restoring to its pre-zoomed size and position after quitting and relaunching, 
regardless if it was maximized when the app was quit.) The former is by design; 
the latter a bug.
  Are you doing anything tricky? Just launching, zooming, and quitting? If so, 
can you pin down which tricky thing is causing the problem? (I've tried some more 
complicated steps; still no problems.)
  It's also working correctly on the couple of other Mac machines I hunted down 
and tried it on. I don't see any problems here.

Comment 11

19 years ago
Sigh. I'm not seeing this in today's (10/23) build. Go ahead and disregard my
comments and mark this bug as appropriate to the original problem. If something
similar comes up later, I'll open a new bug.
Assignee

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID
Assignee

Comment 12

19 years ago
Alrighty then. This bug as originally reported complained that Linux builds don't 
persist window positions between launches. This is done intentionally (the only 
#ifdef XP_UNIX in nsXULWindow.cpp in the current revision, 1.53), since unix 
types seem to prefer that Mozilla not override the window positioning provided by 
their window managers. So, I'm conking this bug as "invalid."
*** Bug 24364 has been marked as a duplicate of this bug. ***
*** Bug 69895 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.