Next F3 press after manually closing find toolbar causes find toolbar to reappear, and not timeout after 5 seconds

RESOLVED DUPLICATE of bug 256420

Status

()

Toolkit
Find Toolbar
RESOLVED DUPLICATE of bug 256420
13 years ago
10 years ago

People

(Reporter: Thomas Rutter, Unassigned)

Tracking

1.8.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051001 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051001 Firefox/1.4.1

If you close the find toolbar by clicking the red 'X' icon, the next time you
press F3 the find toolbar opens again, but this time it doesn't time out and
disappear after 5 seconds.

This occurs when you close the find toolbar by clicking the red 'X'.  It doesn't
occur if the find toolbar was previously closed by timeout.

Reproducible: Always

Steps to Reproduce:
1. Open the find toolbar and type some text into the "Find:" box
2. Close the find toolbar by mouse clicking on the red 'X'.
3. Press F3

Actual Results:  
Find toolbar appears, with the text I entered previously in the box.  Find
toolbar doesn't disappear after 5 seconds.

Expected Results:  
The find toolbar shouldn't appear, because there's already a search term to
search for and I just want to "Find Next".

This seems to be a recent regression.

This is similar to bug #256420 but occurs in a different situation (see steps to
reproduce in this bug).
Worksforme, in both that same branch build and today's trunk. Am I doing
something wrong, is there an essential step missing or particular page, or are
you seeing it in a profile with an extension that's messing things up?

My complete steps: start with firefox -p, create a new profile, paste the URL
for this bug in the urlbar, type ctrl-f, type |find| in the findbar, click the
red X, type F3, find bar doesn't reopen.
(Reporter)

Comment 2

13 years ago
Just tried with a brand new profile.  I'm using Mozilla/5.0 (Windows; U; Windows
NT 5.1; en-US; rv:1.8b5) Gecko/20051001 Firefox/1.4.1.

The bug still exists, and I am still able to reproduce every time using the same
steps to reproduce as you gave.

Extensions installed:
- Dom Inspector
- Reporter
- Talkback

Could this be OS-specific?

I looks like this may be a focus issue too.  Normally, when the find toolbar is
open I can simply click in the main window somewhere and it removes focus from
the find toolbar, making it close.  However, I've noticed that if the find
toolbar was invoked with F3 in the manner shown above, taking focus away from
the toolbar no longer makes it go away.  It remains on screen.
(Reporter)

Comment 3

13 years ago
Note: I think I may have discovered why you were unable to reproduce it.

The 'some text' that you type into the find toolbar cannot already exist on the
page.

So if you typed |find| into the toolbar which viewing this page, the bug won't
occur as that search term is found on this page.
Well, and if you expected it to timeout, you probably weren't using exactly my
str, since ctrl-f finding doesn't seem to have ever done that on a not-found.

So, complete str which worked as expected in 20050519 and failed in 20050729 (I
don't seem to have builds in between, though someone interested could get them
from http://archive.mozilla.org):

1. Start FAYT by typing |/|
2. Type something that's not found in the page
3. Click the red X, or don't, it doesn't actually matter if it times out
4. Type F3 to find the not-found thing again

Meh. Accidental regression or intentional fix, that seems like better design to
me: I fail to find something, and then I try to find the thing that isn't there
again, I probably ought to stare at what I searched for until I realize I
mistyped it.
Definitly bug

If the findbar pops up for the repeat , you'll see the text (in the find input)
beeing highlighted, expecting it to be selected, now press ctrl-C to copy the
string to clipboard and paste is somewhere.
Well, it won't happen, the clipbaord does not have the string.

Also, via keyboard there is no simple way to change the string, you'll have to
press tab to select "match case" and than shift-tab to select the find input

(haven't checked if this bug is a dupe)

Comment 6

13 years ago
Marked as a duplicate of bug 256420.  The method of closing the Find box (step 2) seems immaterial (see bug 256420, comment 16).  Feel free to argue for "unduping" if you can show that the method is significant.

*** This bug has been marked as a duplicate of 256420 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 1.5 Branch

Comment 7

13 years ago
Comment 5 may refer to a different bug.
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.