textbox with value in toolbar crashes [@ nsCSSFrameConstructor::ConstructFrame] firefox

RESOLVED WORKSFORME

Status

()

Core
Layout
--
critical
RESOLVED WORKSFORME
13 years ago
7 years ago

People

(Reporter: Henrik Gemal, Unassigned)

Tracking

({crash})

Trunk
All
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

22.26 KB, application/x-xpinstall
Details
(Reporter)

Description

13 years ago
I have an extension that has the following line within a toolbar:

<textbox textLength="5" value="test" />
this crashes firefox at startup

changing it to:
<textbox textLength="5" value="" />
fixes it so it doesn't crash at startup.

it's an extension that provides it's own toolbar

talkback:
TB10102251Q
TB10101644H
TB10101283Z
Keywords: talkbackid
(Reporter)

Comment 1

13 years ago
perhaps this should be moved to CSS since the crash happens  in
nsCSSFrameConstructor::ConstructFrame 26cb3991
Assignee: nobody → dbaron
Component: XUL Widgets → Style System (CSS)
Product: Toolkit → Core
QA Contact: xul.widgets → ian
Hardware: PC → All
Version: unspecified → Trunk
Assignee: dbaron → nobody
Component: Style System (CSS) → Layout: Misc Code
QA Contact: ian → layout.misc-code
Henrik, do you have the extension somewhere, where I can install it?
(Reporter)

Comment 3

13 years ago
Created attachment 198895 [details]
xpi that crashes firefox
Thanks, but I'm not getting a crash from that extension, using 2005-10-06 winxp
trunk build.
Maybe the crash depends on another thing also you have on your computer?

From talkback ID TB10101644H:
nsCSSFrameConstructor::ConstructFrame 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/base/nsCSSFrameConstructor.cpp,
line 7607]
nsCSSFrameConstructor::ProcessChildren 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/base/nsCSSFrameConstructor.cpp,
line 11604]
nsCSSFrameConstructor::ConstructXULFrame 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/base/nsCSSFrameConstructor.cpp,
line 6302]
nsCSSFrameConstructor::ConstructFrameInternal 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/base/nsCSSFrameConstructor.cpp,
line 7740]
nsCSSFrameConstructor::ConstructFrame 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/base/nsCSSFrameConstructor.cpp,
line 7624]
nsCSSFrameConstructor::ProcessChildren 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/base/nsCSSFrameConstructor.cpp,
line 11604]
nsCSSFrameConstructor::ConstructDocElementFrame 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/base/nsCSSFrameConstructor.cpp,
line 4525]
nsCSSFrameConstructor::ContentInserted 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/base/nsCSSFrameConstructor.cpp,
line 9114]
PresShell::InitialReflow 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/layout/base/nsPresShell.cpp,
line 2725]
nsXULDocument::StartLayout 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/content/xul/document/src/nsXULDocument.cpp,
line 2071]
nsXULDocument::ResumeWalk 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/content/xul/document/src/nsXULDocument.cpp,
line 3099]
nsXULDocument::OnStreamComplete 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/content/xul/document/src/nsXULDocument.cpp,
line 3383]
nsStreamLoader::OnStopRequest 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/netwerk/base/src/nsStreamLoader.cpp,
line 120]
nsJARChannel::OnStopRequest 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/modules/libjar/nsJARChannel.cpp,
line 712]
Component: Layout: Misc Code → Layout
Summary: textbox with value in toolbar crashes firefox → textbox with value in toolbar crashes [@ nsCSSFrameConstructor::ConstructFrame] firefox
QA Contact: layout.misc-code → layout

Updated

13 years ago
Severity: normal → critical
Keywords: talkbackid

Comment 5

13 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051123 Firefox/1.6a1

WFM in a debug build from the 23rd, and in a trunk tinderbox build from the 25th.

Comment 6

13 years ago
*** Bug 317749 has been marked as a duplicate of this bug. ***
Is this still an issue in current trunk builds?  If I unstall that XPI in a current trunk firefox it seems to always be checking for updates to it (and the extension never gets enabled)....
(Reporter)

Comment 8

12 years ago
it works for me now also
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsCSSFrameConstructor::ConstructFrame]
You need to log in before you can comment on or make changes to this bug.