Scheme (https) lost when modifying url proposed by autocomplete

RESOLVED DUPLICATE of bug 239684

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 239684
13 years ago
13 years ago

People

(Reporter: Jerome Lacoste, Unassigned)

Tracking

1.5.0.x Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
In the case I have a browsing habit of going to a particular web site that
requires to use https, the autocomplete feature will not prefix the address
using the https scheme if I start modifying the selected choice.

E.g.

I am used to go to:

https://bugzilla.domain.com/

When I type 'bu' in my address bar, the first address that matches is:

https://bugzilla.domain.com/show_bug.cgi?id=202948

I want to modify the issue number. So I select the address, and start modifying
the issue. But the address that gets printed in my url bar is 

  bugzilla.mozilla.org/show_bug.cgi?id=202948

The scheme is lost.

It's really frustrating in my use case. Because I do hundreds of times per week.

Comment 1

13 years ago
This is a dupe - I will have a look around

Comment 2

13 years ago
Got it - bug 239684

*** This bug has been marked as a duplicate of 239684 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

13 years ago
You beat me. I just found the duplicate bug. I had searched with the wrong
keywords. Sorry for the issue.
You need to log in before you can comment on or make changes to this bug.