Evil xul testcase - involving xbl - causes crash [@ nsIFrame::GetStateBits]

VERIFIED FIXED

Status

()

Core
Layout
--
critical
VERIFIED FIXED
13 years ago
13 years ago

People

(Reporter: Martijn Wargers (zombie), Assigned: bz)

Tracking

({regression, testcase})

Trunk
x86
Windows XP
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
The testcase that I'll attach to the bug crashes Mozilla.
It seems a regression, it doesn't crash in 2005-03-17 build, it crashes in
2005-03-18 build:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2005-03-17+08%3A00%3A00&maxdate=2005-03-18+09%3A00%3A00&cvsroot=%2Fcvsroot
Because of bug 283385, perhaps?
(Reporter)

Comment 1

13 years ago
Created attachment 198317 [details]
testcase

Clicking on the button crashes Mozilla.
(Reporter)

Comment 2

13 years ago
Created attachment 198318 [details]
Bactrace from debug build
(Reporter)

Updated

13 years ago
Summary: Evil xul testcase - involving xbl - causes crash → Evil xul testcase - involving xbl - causes crash [@ nsIFrame::GetStateBits]
This is basically the same problem as bug 291902
Depends on: 291902
Assignee: nobody → bzbarsky
Fixed by patch for bug 291902.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Verified FIXED with SeaMonkey 1.1a;Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv:1.9a1) Gecko/20051020 SeaMonkey/1.1a using this testcase:
https://bugzilla.mozilla.org/attachment.cgi?id=198317
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.