undef error - Connection refused at /usr/lib/perl5/5.8.6/CGI/Carp.pm line 314. when creating/changing a bug

VERIFIED INVALID

Status

()

Bugzilla
Creating/Changing Bugs
VERIFIED INVALID
13 years ago
13 years ago

People

(Reporter: Ferindo Middleton Jr, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050908 (No IDN) Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050908 (No IDN) Firefox/1.4

I'm running  Bugzilla  Version 2.20rc2 on a Linux machine. One day while trying
to create a bug I started getting this unexplained error message. More than
anything, the bug is a nuissance because whenever I create any new bugs or
modify this bug, I get this error message:

"undef error - Connection refused at /usr/lib/perl5/5.8.6/CGI/Carp.pm line 314."

Ferindo

Reproducible: Always

Steps to Reproduce:
1. Go to https://ww2.sleekcollar.com/bugzilla-2.20rc2/show_bug.cgi?id=11
2. Try to "Commit a change"
3. See the Error message described in the Details of this bug report

or 

1. Go to https://ww2.sleekcollar.com/bugzilla-2.20rc2/
2. Try to create a New Bug
3. See the Error message described in the Details of this bug report


Actual Results:  
I get the following error message:
"
Internal Error

Bugzilla has suffered an internal error. Please save this page and send it to
fmiddleton@sleekcollar.com with details of what you were doing at the time this
message appeared.

URL: https://ww2.sleekcollar.com/bugzilla-2.20rc2/process_bug.cgi
undef error - Connection refused at /usr/lib/perl5/5.8.6/CGI/Carp.pm line 314.
"

Expected Results:  
It should display a confirmation message, like Bugzilla normally does on the
process_bug.cgi, indicating that the changes were successfully made.

This appears to only happen to bug number 11 of my Bugzilla installation and any
bugs created thereafter... It appears that if you try to modify a bug created
before bug 11 you don't get this error. This error only happens to bug 11 when
trying to Commit changes and when adding a New Bug.

The changes appear to Save to the database in spite of this error message so, at
this point, this message is primarily a major nuissance. This is to say that if
I go back to search for the bug being created or the changes to the bug, you
will see that the changes where saved, in spite of the error message.
(Reporter)

Updated

13 years ago
OS: Windows 2000 → All
Hardware: PC → All
Version: unspecified → 2.20
"Connection refused"  -- smtp server problem (bugzilla couldn't connect to your
smtp server as it wasn't running on the configured server).

marking as invalid (because it's not a bugzilla "bug").


if you require further help with this issue your best bet is to post to
mozwebtools (see http://www.bugzilla.org/support/).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

13 years ago
I really think this is really a bug because the error only occurs on this one
particular bug on my installation and all others bugs created thereafter. This
one bug just spawns the errors for all future bugs.

All bugs before Bug 11 on my install "Commit" just fine without errors.

Additinally, Bugzilla -does- save the commits which means the SMTP connection
must actually be up and communicating as needed.

This has got to be some kind of bug. of Why else would the problem be isolated
to one particular bug occurence...

Ferindo
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

13 years ago
It's still a support issue and highly unlikely to be an actual bugzilla bug.

Use the support resources on the bugzilla.org website.  In the highly unlikely
event that it turns out to be a bugzilla bug, then, we'll open a bug to fix the
specific problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

13 years ago
I acknowledge that this is not really a bug. It was due to a misconfiguration
with my Sendmail configuration. After fixing my sendmail configuration, the "so
called bug" doesn't occur any longer so I'm confirming that it's not really a
bug. Sorry for waisting anyone's time.

Ferindo
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.