Bug 311004 (VLCSTALL)

Plugin VLC(videolan) wont play or show mp3 audio or wmv, quicktime movies.

RESOLVED INVALID

Status

RESOLVED INVALID
13 years ago
3 years ago

People

(Reporter: factorf2, Unassigned)

Tracking

({qawanted, testcase})

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20051003 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20051003 Firefox/1.0.4

-This page looks wrong in Mozilla. Other browsers display it correctly. You suck! 
- Now for someting completly different.- <poke><poke><nudge><nudge>

Well I have tried this page in the Konq KDE's Browser and it works fine.
so the Plugin is not broken. Things to note. FireFox uses Xembed for plugins.
Konqueror does not have support for the newer and better Xembed hooks only the
NS4 plugins. 


Reproducible: Always

Steps to Reproduce:
1.get vlc plugin:
http://nightlies.videolan.org/

2: compile or install per this page:
http://www.videolan.org/doc/play-howto/en/ch04.html#id2959771

3.you dont need to install the vlc player just grab the VLC plugin from the
mozilla directory and place it in the firefox plugins directory.

4.Start up Firefox or Seamonkey.

5:go to test page i.e. http://www.apple.com/trailers/fox/transporter_2/hose.html

Actual Results:  
A blank spot where the movie should be or a black window that says (no picture).
No active media will be played.
Also debug error info when media is being activated.

For video/quicktime found plugin
/home/factor/mozilla-firefox-1.0.4.orig/dist/bin/plugins/libvlcplugin.so
WARNING: NS_ENSURE_TRUE(fCallbacks->newp) failed, file
ns4xPluginInstance.cpp, line 966
WARNING: NS_ENSURE_TRUE(peer) failed, file
ns4xPluginInstance.cpp, line 934
nsPluginNativeWindowGtk2: NPPVpluginNeedsXEmbed=0
nsPluginNativeWindowGtk2: call SetWindow with xid=0x3601c56


Expected Results:  
View good movie trialer embedded inside the web page.
Which can also be controlled via javascript, but not this example.

I have used to test this with these browsers:
Seamonkey current.
Firefox 1.0.4, 1.0.7 and 1.5 Deer Park beta 1 and 2
Konqueror current

moz dev 1.7.0 - 1.7.8

Konqueror supports only NS4 plugins.
Firefox seems to only support Xembed and does not fall back to the older style .
  
I have left information at both Mozilla sites and VLC sites on this problem.
Both Debian(3.1) and RedHat(FC4) suffer these problems.
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Summary: Plugin VLC(videolan) wont play or show mp3 audio or wmv, quicktime movies. → Plugin VLC(videolan) wont play or show mp3 audio or wmv, quicktime movies.
Version: unspecified → Trunk
(Reporter)

Comment 1

13 years ago
This is a very good plugin, open source and gives much control over media with
javascript. Which is why I want to use it and keep away from having to use
flash by using media that is built into the OS itself and works on all operating
systems so everyone can enjoy the works of the plugin. But currently it only
works in the Konqueror. So this limits this plugin form gaining ground on
Windows operating system. Although I dont use Windows since it is not a mans
operating system it is a good operating system for girls and I would like for
more girls to view my pages with this capability.
Alias: VLCSTALL
Component: Plug-ins → General
Keywords: embed, helpwanted, testcase, topembed
Product: Core → Firefox
QA Contact: plugins → general
Version: Trunk → 1.5 Branch

Comment 2

13 years ago
Go bug the VLC people about it, since it most definitely seems to be their problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

13 years ago
This also happens with the Adobe PDF plugin but I have not studied the Adobe pdf
error as I have with this one, and bwecasue it works in the konqueror, Mozilla
should also handle the same plugins.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 4

13 years ago
Then it's obviously something wrong on your end if plugins are not working with
your firefox version (which happens to be pretty outdated anyways, and your UA
string makes no sense at this time).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

13 years ago
I stated in the comments that others have also tried it and suffer the same result
I have done much study on this issue. It seems to be a problem with the Xembed
fall back to the older style of plugins. this is not an isolated incident. Other
systems are having the same problem. also it happens on Knoppix 4.0 as well as
red hat and debian.
(Reporter)

Comment 6

13 years ago
Note the same error occurs on the FireFox 1.5 branch I am just using my current
compiled firefox right now to enter this error report but it happens on
1.0.4-1.5 version of Firefox.
(Reporter)

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 7

13 years ago
If the plugin is failing like that, because it doesn't want to play nice with
firefox, it's not coded correctly, and is the plugin's fault. For christs sake,
if firefox was to be molded to work with every possible plugin available,
imagine how bloated the code would get.

Oh and I'm removing all the keywords except testcase since testcase is the only
one that actually applies to this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Keywords: embed, helpwanted, topembed
Resolution: --- → INVALID
Reopening.  Aaron, please move bugs to the right component before resolving
them, ok?  And if you _are_ going to mark them invalid, there should be a good
reason.  I don't see any data here indicating that the bug is in the plugin, and
we've certainly had our share of bugs in our plugin code.

So what needs to happen here is some checking on exactly what's going on instead
of knee-jerk invaliding.

> For christs sake, if firefox was to be molded to work with every possible
> plugin available, imagine how bloated the code would get.

No need to imagine.  I suggest afternoon reading of the plugin code for some of
the fun workarounds we had to put in to work with some plugins.  ;)  Usually
because the plugin API was so badly documented the plugins couldn't get it
"right" even if they'd tried.  Again, interaction between the plugin and Firefox
has two sides to it, and the Firefox side is not always right.
Status: RESOLVED → UNCONFIRMED
Keywords: qawanted
Resolution: INVALID → ---
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Version: 1.5 Branch → 1.8 Branch
like I said on IRC already, this is not related to XEmbed, as proven by this
message:
WARNING: NS_ENSURE_TRUE(fCallbacks->newp) failed, file
ns4xPluginInstance.cpp, line 966

I wish you had pasted the error as shown on deer park, instead of 1.0._4_
(Reporter)

Comment 10

13 years ago
(In reply to comment #9) 
> like I said on IRC already, this is not related to XEmbed, as proven by this 
> message: 
> WARNING: NS_ENSURE_TRUE(fCallbacks->newp) failed, file 
> ns4xPluginInstance.cpp, line 966 
>  
> I wish you had pasted the error as shown on deer park, instead of 1.0._4_ 
 
 
Here is the error for DEERPARK alpha 1 
[00000001] main vlc error: interface "hotkeys,none" initialization failed 
[00000022] main interface error: no interface module matched "screensaver" 
[00000022] main interface error: no suitable intf module 
[00000001] main vlc error: interface "screensaver" initialization failed 
 
Visually you will get the black box with the words (no picture) 
with the testcase web link. 
 
Those are messages from the plugin.  Are there no errors in Gecko code anymore?
(Reporter)

Comment 12

13 years ago
Sorry, I don't have the source code to the alpha of deer park can you point me 
to the source so I can add brake points and compile it and get debug data out 
of it. All I could find was the binary. I would be happy to compile it to 
further debug.  
 
But the same problem persist "no change" in the outcome from the 1.0.4 to Deer 
Park. 
 
Thanks, 
 
(Reporter)

Comment 13

13 years ago
(In reply to comment #12) 
> Sorry, I don't have the source code to the alpha of deer park can you point 
me  
> to the source so I can add brake points and compile it and get debug data out  
> of it. All I could find was the binary. I would be happy to compile it to  
> further debug.   
>   
> But the same problem persist "no change" in the outcome from the 1.0.4 to 
Deer  
> Park.  
>   
> Thanks,  
>   
 
Found it. Will compile and put thetest result here in a few. 
(Reporter)

Comment 14

13 years ago
I had compiled all day but all I got out of the beta was a segfault so I will 
not get to run Firefox to gather more debug data. unless someone else that has 
can follow the steps to see what error they get. 
Is your plugin compiled with --enable-quicktime or something?  I can't get that
to compile (on RedHat).
(Reporter)

Comment 16

13 years ago
Thanks, no I compile with  
--enable-mozilla  
Then why would it be able to play quicktime content (which is what
http://www.apple.com/trailers/fox/transporter_2/hose.html has on it)?
In any case, running a debug vlc plugin (compiled with:
--prefix=/home/bzbarsky/test --disable-dvd --disable-mad --disable-ffmpeg
--disable-libmpeg2 --enable-mozilla --enable-debug) I get no errors from either
the plugin or Gecko on the apple site -- just the plugin showing a black
rectangle with a white "no picture" message.
(Reporter)

Comment 19

13 years ago
(In reply to comment #18)  
> In any case, running a debug vlc plugin (compiled with:  
> --prefix=/home/bzbarsky/test --disable-dvd --disable-mad --disable-ffmpeg  
> --disable-libmpeg2 --enable-mozilla --enable-debug) I get no errors from  
either  
> the plugin or Gecko on the apple site -- just the plugin showing a black  
> rectangle with a white "no picture" message.  
  
 (In reply to comment #18) 
> In any case, running a debug vlc plugin (compiled with: 
> --prefix=/home/bzbarsky/test --disable-dvd --disable-mad --disable-ffmpeg 
> --disable-libmpeg2 --enable-mozilla --enable-debug) I get no errors from 
either 
> the plugin or Gecko on the apple site -- just the plugin showing a black 
> rectangle with a white "no picture" message. 
 
That is exactly what I got. 
Thanks for the confirmation on that. 
I have also left information at the VLC site on what errors 
I have gotten. I think I will set some brake points in the older 
 version to further debug. 
 
(Reporter)

Comment 20

13 years ago
 Ok I have gotten it to work with the help from the videolan maintainer
to get it to work, I had to upgrade from debian stable or sarge 3.1 to
unstable or sid and had to use the VLC version 0.8.4 or later

I had used 0.8.4 before but did not work until I upgraded the support libs with
the unstable version of debian.

The older version of VLC supported NS4 style plugins and did not support the
Xembed style. While the new version of VLC supports the Xembed and not the 
older NS4 style. Thus I came to this conclusion becasue VLC worked on konq
before I upgraded and now no longer works on konq, but works on Firefox after
the upgrade. So dont know if tis is true or not just the way it worked out for me.
 
When I get the time I may look into why it no longer works, but for now I am
happy it works in Firefox just fine. Here is the demo page for VLC to try for
yourself.
http://altair.videolan.org/~dionoea/vlc-plugin-demo/plugin.php?url=http://vthr.videolan.org/~dionoea/vlc-plugin-demo/streams/sw_8M.mov&width=320&height=180

I will go ahead and close this bug but the ns4 plugin may still be a problem for
other older plugins.
 
 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 21

13 years ago
Not a firefox bug, nothing was fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 22

13 years ago
Sorry just got it to work in konqueror, but no javascript hooks or controls work
under the konq would be the correct outcome. while all of it now works under
firefox. just thought I would send that info for future refrence.

Thanks all for the help.

Updated

9 years ago
Component: Plug-ins → VLC (VideoLAN)
Product: Core → Plugins
QA Contact: plugins → videolan-vlc
Version: 1.8 Branch → unspecified
(Assignee)

Updated

3 years ago
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.