ff uses huge ram if used for large time.

RESOLVED INVALID

Status

()

RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: subscrive, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.10) Gecko/20050717 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

I am using one instance of FF 1.0.6 since few weeks. the memory usage shows 270 MB!
The performance of FF is also slow. The performance of various other
applications are OK. New instance of FF is OK. 

I have heavily used the multitab feature.

Reproducible: Always

Steps to Reproduce:
1. use single instance of FF for more 2 weeks daily.
2. the usage should be very heavy.
3. close all the extra tabs of the FF instance.

Actual Results:  
a. the performance is slow.
b. mem usage shown in task manager is 270 MB.

Expected Results:  
a. performance should be fast.
b. mem usage should be same as the new instance.

Comment 1

13 years ago
This should be better in a newer version of Firefox.  Duping to one of many bugs
about memory usage (aribitrarily chosen).

*** This bug has been marked as a duplicate of 131456 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 2

13 years ago
This kind of report is not useful. What is useful is creating a clean profile, getting a nightly, and trying to reproduce and analyze the leaks using the available tools. See
http://www.squarefree.com/2006/01/13/memory-leak-detection-tool/
http://dbaron.org/log/2006-01#e20060110a

Closing this bug as WFM, because it will not lead to useful fixes to the code.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

13 years ago
I am an end user.

Dont expect me to do all the de bugging.

Also everyone knows that ff leaks memory.

reopening - till the bug gets solved and I see it in my update.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 4

13 years ago
This is reproducible even on 1.5.0.1.

Comment 5

13 years ago
As an end user you should try to get help at http://forums.mozillazine.org

Bugzilla is not the place for you to track your issues with the product, it's a tool for people working on the product to track fixable issues. There are a number of bugs on memory leaks, we don't need another *unspecific* one. If you come up with something more specific (see links in comment 2), please do file a bug.

You might also want to read bug 213534 comment 38, in case you don't believe _me_.

Re-resolving.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.