We need to give the user an option whether to have Password Manager automatically fill in the password or not. The use of a specially assigned key would be useful.

RESOLVED DUPLICATE of bug 376668

Status

()

Toolkit
Password Manager
--
enhancement
RESOLVED DUPLICATE of bug 376668
12 years ago
10 years ago

People

(Reporter: Sahil Sapre, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 (No IDN) Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 (No IDN) Firefox/1.4

Suppose a user has multiple accounts on a certain website. The Password Manager
automatically fills in the saved password, which could be a pain. It would be
nice to have a special key assigned to this task (like Opera uses Ctrl + Enter
for Wand) so as to make entering login information for multiple accounts and/or
multiple users easier. Obviously, Firefox uses Ctrl + Enter for automatically
entering www and .com before and after the keyword. But a specific key, doesn't
matter which, might be useful.

Reproducible: Always
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051003
Firefox/1.4.1 ID:2005100321

When there are multiple passwords on one site, I see a dropdown-list (after
clicking in the box).
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051003
> Firefox/1.4.1 ID:2005100321
> 
> When there are multiple passwords on one site, I see a dropdown-list (after
> clicking in the box).

Yes, but if the Password Manager has saved a certain username and password,
there's no list, if I'm correct. The default action of the Password Manager,
i.e. entering the saved info right into the fields, is what I'm questioning.(In
reply to comment #1)
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051003
> Firefox/1.4.1 ID:2005100321
> 
> When there are multiple passwords on one site, I see a dropdown-list (after
> clicking in the box).

(In reply to comment #2)
For me, Firefox shows a dropdownlist on sites where there are multiple passwords if:
- Autofill is enabled (Tools > Options > Privacy > Saved Forms > Save
information I enter in forms and in the Search Bar;
- the dropdownlist is not hidden by somes lines in userChrome.css.

Comment 4

12 years ago
See also bug 222653.

Comment 5

11 years ago
*** Bug 358423 has been marked as a duplicate of this bug. ***
*** Bug 358423 has been marked as a duplicate of this bug. ***

Comment 7

11 years ago
is this new feature possible in future versions?

it's really an enhancement :-)

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 376668
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.