The default bug view has changed. See this FAQ.

Some stretchy gryphes dissapear in Deer Park

RESOLVED FIXED

Status

()

Core
MathML
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: YAMASHITA Makoto, Assigned: rbs)

Tracking

({fixed1.8})

Trunk
PowerPC
Mac OS X
fixed1.8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051002 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051002 Firefox/1.6a1

Deer Park a2 on MacOSX has some trouble with stretchy font rendering. Larger
root gryphes are not displayed in the "Torture Test" #13 and so are the
over/underbraces ("glue" part in particular) of #19 and #22.
Zooming in makes these rendered correctly. This problem was not encountered in
Firefox 1.5b (with fontEncoding.properties copied, ref bug #228804 comment #7).
I put the screenshots at
http://www.ms.u-tokyo.ac.jp/~makotoy/ffmath/screenshots.html
Further, I edited mathfontMath2.properties and mathfontMath4.properties to
change the "glue" part of these gryphes to "not relevant to the char" (\uFFFD) like
\u221A = \uF8FF\uFFFD\uF8FF\uFFFD\u221A\uF8FF\uF8FF\uF8FF # Sqrt, radic (the
forth of the right hand side is changed)
and got preferable rendering, see the screenshot page.
I have no idea what the point in dissociating the glue parts which *become*
rendered quite fine.
Is this specific to Mac? Should this tweak be incorporated as the fix for this
problem, or should we fix the code to avoid similar paradoxes in, say, STIX
migration?


Reproducible: Always

Steps to Reproduce:
1. Download the nightly build of Firefox
2. Go to http://www.mozilla.org/projects/mathml/demo/texvsmml.xhtml
3. See the tests #13, #19 and #22

Actual Results:  
Larger root gryphes disappears, overbraces and underbraces are shattered (no
"glue" parts)

Expected Results:  
Correct rendering like the sample images in the left column
(Reporter)

Comment 1

12 years ago
Firefox 1.5b2 is with this problem (and the same procedure works for it) too.

> I have no idea what the point in dissociating...
Having that said, I now suspect the canges made to
mozilla/layout/mathml/base/src/nsMathMLChar.cpp
(between v1.109 and v1.110 "Prevent gaps in stretchy chars") might have someting
to do with this.
THe glue gryphes from Mathematica fonts look very small in the encoding table, 
they might be cut down to zero-size and causing troubles... So that zooming in
makes this problem dissapear.
I don't know what fix to do so can anybody check this?
(Assignee)

Comment 2

12 years ago
Created attachment 200059 [details] [diff] [review]
patch

This is a regression from bug 307157. I should have been more careful to avoid
turning the glue into nothingness. This patch makes sure to clamp the amount by
which the glue is pretended to be smaller than it is. 

The glue in Mathematica fonts can really be tiny:
http://www.mozilla.org/projects/mathml/fonts/encoding/math4.gif
Attachment #200059 - Flags: superreview?(roc)
Attachment #200059 - Flags: review?(roc)
Attachment #200059 - Flags: approval1.8rc1?

Comment 3

12 years ago
Comment on attachment 200059 [details] [diff] [review]
patch

please don't request approval until you've got sufficient reviews, landed and
been verified on the trunk. Thanks.
Attachment #200059 - Flags: approval1.8rc1?
Attachment #200059 - Flags: superreview?(roc)
Attachment #200059 - Flags: superreview+
Attachment #200059 - Flags: review?(roc)
Attachment #200059 - Flags: review+
(Assignee)

Comment 4

12 years ago
Checked in the trunk.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Assignee)

Updated

12 years ago
Attachment #200059 - Flags: approval1.8rc1?

Comment 5

12 years ago
Comment on attachment 200059 [details] [diff] [review]
patch

too late for non-critical bugs in this release.
Attachment #200059 - Flags: approval1.8rc1? → approval1.8rc1-
(Assignee)

Comment 6

12 years ago
Comment on attachment 200059 [details] [diff] [review]
patch

drivers, I am re-requesting approval because it is a _critical_ fix. Without
it, many of the achievements that have gone into getting MathML on the Mac are
annihilated. As you might recollect from my earlier requests, MathML is all
about appearance. Without this fix, there are ugly "holes" in strecthy MathML
characters, leading to formulas that don't make sense -- we get meaningless
renderings such as these:
http://www.ms.u-tokyo.ac.jp/~makotoy/ffmath/16fntEncdCopied.gif
http://www.ms.u-tokyo.ac.jp/~makotoy/ffmath/16fntEncdCopied2.gif

instead of these correct ones:

http://www.ms.u-tokyo.ac.jp/~makotoy/ffmath/16fntEncdCopiedZoom.gif
http://www.ms.u-tokyo.ac.jp/~makotoy/ffmath/16fntEncdCopiedZoom2.gif
Attachment #200059 - Flags: approval1.8rc1- → approval1.8rc1?

Updated

12 years ago
Attachment #200059 - Flags: approval1.8rc1? → approval1.8rc1+
(Assignee)

Comment 7

12 years ago
Checked in the 1.8 branch.
Keywords: fixed1.8
You need to log in before you can comment on or make changes to this bug.