newsindo.com - utf-8 claims to be shift-jis

RESOLVED INVALID

Status

Tech Evangelism
Desktop
RESOLVED INVALID
12 years ago
3 years ago

People

(Reporter: bayu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

I saw that when i opened that page using IE everything is normal, but when i 
opened using FireFox. There's a different view. I checked at View Source from 
IE and FireFox, and found that FireFox change the html source. Why?

Reproducible: Always

Steps to Reproduce:
1. Visit http://newsindo.com/arisan/atas.htm
2. View Source of that URL from IE and FireFox
3.

Actual Results:  
Different HTML code source. Example. html code </i> was changed into ・/i> by 
FireFox.

Expected Results:  
It should be normal. </i> is not ・/i>

Comment 1

12 years ago
It works correctly if you switch the character encoding to Unicode.

It's not just he view-source, you also see it in the page itself. I'm using
auto-detect and that didn't detect that is was Unicode for one reason.

Note that the page itself contains a content-type header (in HTML, not a
HTTP-header) that falsely claims it's Shift-JIS.

Comment 2

12 years ago
Even with the auto-detector on, the page displays in Shift-JIS, as asked by the
Content-Type header.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051004
Firefox/1.4.1
Assignee: nobody → japanese
Component: View Source → Japanese
Product: Firefox → Tech Evangelism
QA Contact: view.source → japanese
Summary: Firefox change View Source → newsindo.com - utf-8 claims to be shift-jis
(Reporter)

Comment 3

12 years ago
I have edited the HTML source as you requested, but it's still error using 
FireFox. Please open using IE & FireFox.

http://newsindo.com/arisan/atas.htm
(Reporter)

Comment 4

12 years ago
(In reply to comment #1)
> It works correctly if you switch the character encoding to Unicode.
> It's not just he view-source, you also see it in the page itself. I'm using
> auto-detect and that didn't detect that is was Unicode for one reason.
> Note that the page itself contains a content-type header (in HTML, not a
> HTTP-header) that falsely claims it's Shift-JIS.

I have edited the HTML source as you requested, but it's still error using 
FireFox. Please open using IE & FireFox.

http://newsindo.com/arisan/atas.htm

Comment 5

12 years ago
possibly related to bug 168526 (SJIS detector is too sensitive)

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

12 years ago
as pointed in comment 2, it's because of 
<meta http-equiv="Content-Type" content="text/html; charset=Shift_JIS">
in <head>.

that "Shift_JIS" should be "utf-8".
anyone know site admin's address? i would like to let them know.

Comment 7

3 years ago
The page doesn't exist anymore.
Assignee: japanese → nobody
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Component: Japanese → Desktop
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.