Closed Bug 311072 Opened 17 years ago Closed 17 years ago

javascript pop up windows do not work

Categories

(SeaMonkey :: General, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 309775

People

(Reporter: meme111, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20051004 SeaMonkey/1.1a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20051004 SeaMonkey/1.1a

http://www.musiciansfriend.com/srs7/g=guitar/search/detail/base_pid/110436/ 
when you click on view larger photo, that pop up never shows up.  I have enabled
all pop ups from that site but they still do not work.

Thanks

Reproducible: Always
Looks like a normal window.open to me (and also wfm here):
function pop(url, width, height){
  popup = window.open(url, 'popup', 'width=' + width + ',height=' + height +
',scrollbars=yes');
  popup.focus();
  return;
}

Reporter: Do you get any errors in JS Console when clicking that link?
Frank, it also WFM with Firefox 1.4.1 rv: 1.8b5 build 20051003 but it does not
work when using Seamonkey 1.1a rv: 1.9a1 build 2005100405 under XP Pro SP2 here.

I went to the site. This is the calling function:

<A HREF="javascript: pop('/srs7/g=guitar/content/cpd=YZXI/base_pid=110436/',
500, 500);">View Larger Photo</a>

and the file

http://img3.musiciansfriend.com/dbase/js/site.js

has 

function pop(url, width, height){
  popup = window.open(url, 'popup', 'width=' + width + ',height=' + height +
',scrollbars=yes');
  popup.focus();
  return;
}

If I type in the javascript console in the evaluate text box (in Seamonkey 1.1a)
this:
window.open("/srs7/g=guitar/content/cpd=YZXI/base_pid=110436/", "popup",
"width=500,height=500,scrollbars");
and then click the evaluate button, the js console will report:

Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIDOMJSWindow.open]"  nsresult: "0x80004005
(NS_ERROR_FAILURE)"  location: "JS frame :: javascript:
window.open("/srs7/g=guitar/content/cpd=YZXI/base_pid=110436/", "popup",
"width=500,height=500,scrollbars"); :: <TOP_LEVEL> :: line 1"  data: no]

but the same steps with Firefox 1.4.1 in the js console over there will be
carried out without a itch.

On the other hand,
If I type in the javascript console evaluate text box (in Seamonkey 1.1a) this:
window.open("http://www.musiciansfriend.com/srs7/g=guitar/content/cpd=YZXI/base_pid=110436/",
"popup", "width=500,height=500,scrollbars");
and then click the evaluate button, the secondary window pops up as expected and
I get no js console error reported.
reporter, do you have any ad remover / firewall that might remove script that
looks like an ad?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051004
Firefox/1.6a1 ID:2005100413

WFM. Bubba, could you try this in one of the most recent builds? There was some
JS bustage in builds from earlier.
(In reply to comment #2)
> Error: uncaught exception: [Exception... "Component returned failure code:
> 0x80004005 (NS_ERROR_FAILURE) [nsIDOMJSWindow.open]"  nsresult: "0x80004005
> (NS_ERROR_FAILURE)"  location: "JS frame :: javascript: <..>

Related to/duplicate of Core bug 309775?

*** This bug has been marked as a duplicate of 309775 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.