Javascript on Manchesteronline.co.uk causes segfault

RESOLVED INCOMPLETE

Status

()

Firefox
General
--
critical
RESOLVED INCOMPLETE
12 years ago
9 years ago

People

(Reporter: Rich Daley, Unassigned)

Tracking

1.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Firefox/1.0.7 (Debian package 1.0.7-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Firefox/1.0.7 (Debian package 1.0.7-1)

Visiting any page on manchesteronline.co.uk causes Firefox to segfault
immediately after rendering the page.

It works fine with Javascript disabled. 

I'm using Linux Firefox 1.0.7 from the Debian sid package.

The site used to work fine, but I think they changed something at their end
recently (in the last 3 weeks or so) and then I noticed the segfaults. Possibly
the new thing is the external call to some .js file on sublimemedia.net.

If you can't reproduce this, let me know and I'll try some straces or something.

Reproducible: Always

Steps to Reproduce:
1. Make sure javascript is enabled.
2. Visit any page on manchesteronline.co.uk.

Actual Results:  
My browser segfaulted immediately after rendering the page.

Expected Results:  
It shouldn't have segfaulted!

Comment 1

12 years ago
FWIW, works for me on Windows: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.8b4) Gecko/20050908 Firefox/1.4
(Reporter)

Comment 2

12 years ago
Hmm, I've just tried it with an empty profile and it seems to work OK, although
it did pop-up a window the first time (but I can't reproduce it), which I've
never seen in my usual profile.

Is there any way of narrowing down what extension or config option might be
causing this behaviour?

Comment 3

12 years ago
Alright, so it's obvious an extension is causing this. -> INVALID What you need
to do is just disable extensions one by one until you find the culprit.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Comment 4

12 years ago
Alright, since this is a crasher I reopened it. Rich, could you please get a
stacktrace or a talkback ID from the crash? Thanks.
http://kb.mozillazine.org/Talkback 
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Version: unspecified → 1.0 Branch
Please use a recent version of Firefox, available at
http://www.mozilla.com/en-US/firefox/, and report back with your results in
relation to this bug report.

If this problem can be reproduced, please reopen this bug report. Due to age/lack of response, closing. (bug cleaning)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago9 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.