javascript fails to throw exception

RESOLVED WORKSFORME

Status

()

Core
DOM
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Brad, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051004 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051004 Firefox/1.6a1

Instead of throwing an expected exception, this JavaScript code just stops
executing.

var sCurrentLocation = "";
try
{
   sCurrentLocation = String( parent.outerFrame.innerFrame.location );
}
catch ( ex )
{
   sCurrentLocation = "";
}
...


Reproducible: Always

Steps to Reproduce:



Expected Results:  
An exception should have been thrown and code should have resumed executing.
Created attachment 198500 [details]
testcase

Something like this?

Updated

13 years ago
Component: General → DOM
Product: Firefox → Core
Version: unspecified → Trunk

Updated

13 years ago
Assignee: nobody → general
QA Contact: general → ian
Strange I get an alert with the url of bugzilla and alert 3, but I would expect
alert 'failed' and alert 3.
(Reporter)

Comment 3

13 years ago
This test case isn't what I'm experiencing as this case works the same in both
1.0.6 and 1.5 Beta 2. What I'm experiencing works in 1.0.6, but not in 1.5 Beta
2. I'll try to narrow down a test case which shows the problem.
Brad, any update on the testcase?
(Reporter)

Comment 5

13 years ago
I've been a bit too busy to write up a test case that shows the bug, but I can
walk you through reproducing it in the application where I am experiencing it.

http://www.sane.com/demo/NetTracker/web/index.html

1. In the menu on the left, click "Visitor Analysis"
2. Click "Host"
3. Click the link "pppch158134.du.dacom.co.kr"
This link loads a page off-site to perform a domain lookup.
The menu at the left no longer functions as far as loading pages into the main
frame.

This works correctly in released versions of Firefox (and every other browser
I've tried), but not in the daily build as of Mozilla/5.0 (Windows; U; Windows
NT 5.1; en-US; rv:1.9a1) Gecko/20051017 Firefox/1.6a1.

Sorry I don't have anything more concise.

Updated

13 years ago
Keywords: regression
Ok, I tried backing out with bug 245890 and bug 252289, but they don't seem to
be the cause of this regression.
bsmedberg mentioned bug 242234 as a possible cause.
Hmm, this is WORKSFORME now with 2005-10-28 trunk build and 2005-10-29 branch build.
Brad, could you verify?
(Reporter)

Comment 9

13 years ago
WORKSFORME as of Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Ok, great! Marking WFM then.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.